Unified Functional Testing Practitioners Forum

UFT can't identify object on Firebox and Chrome.

Go to solution

UFT can't identify object on Firebox and Chrome.

I installed uft 11.50 and the following patchs as below:


and right now my uft version is 11.51 bulid 0561

As the patch UFT_00056 says, it will support chrome 27,28 and 29 beta; firefox 22 and 23 beta

But it not work for me, the uft can't identify the chrome and firefox as a brower, even I used the lower version of the chrome(21,26) or firefox(20,21). the object spy always identify chrome and firefox as a window.


Could anybody give me some advice and help me out? Thank you very much!

Valued Contributor.

Re: UFT can't identify object on Firebox and Chrome.

Hi ,


If UFT is able to Internet Explorer as a browser, most probably the UFT extension/plugin for Chrome and Firefox are not enabled.

In order to check this, start Firefox/Chrome as administrator, open Settings->Extensions and make sure the 'Unified Functional Testing Agent/Plugin' is enabled.

Also, please make sure that UFT is not configured to Record and Run on specific browsers only; in UFT menu go to Record -> Record and Run Settings and select the option 'Record and Run on all browsers'




Re: UFT can't identify object on Firebox and Chrome.

Thank you so much, you save MY LIFE!!! IT WORKS NOW!!!
New Member.

Re: UFT can't identify object on IE 9,10,11 during runtime, though it identifies inconsistently..

QTP is not identifying entire hierarchy of the object in the middle of my script execution and my script will eventually fail.

Below is what happening

After opening my application, my script performs certain operations. At the end of the execution when I spy any object on the page, nothing but the page is being identified. So my hierarchy in the spy is Browser and Page. It works good if refresh the browser and spy again.

At that moment the browser name property is loosing it value though it has the name in normal time.

I tried few ways like un-checking the Enable Protected mode security checkbox.

Also verified the Integrity level of QTP and IE processes and found them out to be medium.

The interesting part with the IE browser on my machine is even if only one browser with one tab is opened and running on the desktop, there are 2 iexplore.exe processes on the task manager.

Can some one please help me how to resolve this issue? do we have any patches???


Simillar Issue, but now in UFT12.02