Unified Functional Testing Practitioners Forum

QTP: ActiveX component can't create object: 'QuickTest.RunResultsOptions'

Super Contributor.

QTP: ActiveX component can't create object: 'QuickTest.RunResultsOptions'

Greetings, I have prepared a VBscript for QTP which is working fine, but when I tried to use the same script in another server's QTP it shows me this error message "QTP: ActiveX component can't create object: 'QuickTest.RunResultsOptions'". I have tried some of the solutions provided here link but is still unable to resolve it. Is there any other solutions and possible cause for this issue?


Micro Focus Expert

Re: QTP: ActiveX component can't create object: 'QuickTest.RunResultsOptions'



Please consider following causes for the problem:


1. Not sufficient permissions on the machine and/or UAC/DEP is turned on.

Check required minimum permissions here: http://support.openview.hp.com/selfsolve/document/KM183747


2. QTP installation or specific class corrupted.

Try repairing the QTP installation and/or reregistering its dll files.

If this does not help, you should proceed with clean reinstall of the product (with full admin rights as well as UAC&DEP disbaled): http://support.openview.hp.com/selfsolve/document/KM171368


3. Following bug by Microsoft: http://support.microsoft.com/kb/311269/en-us


4. If your machine is 64bit, also consider wrongfully lauching the .vbs from 64bit Wscript.exe or CScript.exe instead of the 32bit versions.

Force the use of the 32bit version of the scripting host by either of following ways:

  • Call the VBS file manually with the following line: c:\windows\SysWOW64\cscript.exe C:\test.vbs
  • Rightclick on VBS file, go to "Open with" and modify the default behavior pointing to the cscript.exe mentioned in above point.




“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Super Contributor.

Re: QTP: ActiveX component can't create object: 'QuickTest.RunResultsOptions'

Thank you for your reply, to answer the questions:
1. The UAC is disabled and the user is administrator.
2. QTP installation repaired.
3. I tried that fix but the symptom still can be reproduced.
4. The machine is not 64-bit.