Unified Functional Testing Practitioners Forum

Object Spy not working

Acclaimed Contributor

Object Spy not working

I'm considering purchasing HP Unified Functional Testing and downloaded the UFT free evaluation.  I'm going through the tutorial and can't seem to get the object spy to work.  When I hover the cursor over various objects on the Mercury Tours website from the tutorial it does not recognize them.  The tutorial said to make sure to view page at 100% which I am doing.  Still not working.  Any adivice? 

Occasional Advisor

Re: Object Spy not working

With which browser are you trying to do that?

I'm facing the same issue with FF and Chrome but with IE10 everything works fine.

It seems that UFT doesn't support the latest versions of these browsers.

Acclaimed Contributor

Re: Object Spy not working

I am using IE10


Re: Object Spy not working

You need to check two things:

Firstly , while installing, which are the add ins that you have selected.


You need to have active X, web and .net addins selected.


Secondly, you need to set record settings:

Record -> Record and Run settings -> Web

You can select Record and run test on any open browser



HPE Expert

Re: Object Spy not working

Hello ,


Support for IE 10 was provided only from Service pack 1 (SP1 ) of UFT. UFT 11.50 GA doesn't support IE 10.

And this support for IE 10 was only on WIndows 8 machines.


With SP2 of UFT , IE 10 is supported on Win 7 also.


If you already haven't installed SP2 , install SP2 patch for UFT 11.50 to test IE 10 on Win 7 or Win 8 or Win server 2012.


Link for the patch is http://support.openview.hp.com/selfsolve/document/KM00447986



[If this post or any other post helps to resolve your issue or query, mark the thread as solved and give KUDOS to the author for their assistance. ]

( Posts and opinions made here are my own and do not reflect the opinions of my employer HPE in any way . )
//Add this to "OnDomLoad" event