Unified Functional Testing Practitioners Forum
cancel

ActiveX component can't create object TDApiOle80.TDConnection

Vinod_Nag
Occasional Advisor

ActiveX component can't create object TDApiOle80.TDConnection

Unable to create QC connection object using VBscript. Mine is a Sys32 machine. While I am trying to create an object for QC connecion I am getting "ActiveX component can't create object TDApiOle80.TDConnection" error. 

Please suggest me how to overcome this error.

4 REPLIES
Kevin_Dsouza
Super Collector

Re: ActiveX component can't create object TDApiOle80.TDConnection

I am observing this issue after installing the ALM 12 evaluation version in Win server 2008 x64 R2 SP1....pls advise!!
vzamoraz
HPE Expert

Re: ActiveX component can't create object TDApiOle80.TDConnection

Hello,

 

      Access the machine with full administrator rights user and Disable de User Account control (UAC)

 

Regards.

 

 

Note: The Opinions expressed in my post are mine alone, and do not reflect the opinions of my employer. No warranties express or implied for any answered posted.

 

Also remember if you have a valid contract with HP feel free to visit our FT/QTP Support Customer Forums:

http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test

You can create an account with your HP credentials

Highlighted
pavanpy
Member

Re: ActiveX component can't create object TDApiOle80.TDConnection

This script is being executed in a 64-bit machine I think. If you are using csript to debug the script, then you have to use the following command in cmd:

 

 

"c:\Windows\SysWOW64\cscript.exe   c:\users\xxxxxxxx\Desktop\script.vbs"

 

instead of

 

"csript  c:\users\xxxxxxxx\Desktop\script.vbs"

 

+pavan

Kdas
Acclaimed Contributor

Re: ActiveX component can't create object TDApiOle80.TDConnection

We had the same problem while running a vbs script to fetch data from ALM.

System - Win7 , ALM-11.52

Regsitering the ALM client helped. To do this follow steps as below - 

  1. Open IE as Admin(right click on IE iconà Run as Administrator)
  2. Open  ALM
  3. Help Menu ->ALM Tools -> HP ALM Client Registration Link
  4. In the pop up scroll down and select ‘Register HP ALM’ 
  5. It’ll do some downloads. Once completed close the window

This should fix the problem. If not try running the vbscript from command prompt as below -

c:\Windows\SysWOW64\wscript.exe "<Path of the .vbs file>"

 

Thanks,

Kishore

//Add this to "OnDomLoad" event