UCMDB and UD Practitioners Forum (Previously CMS)
cancel

UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

SOLVED
Go to solution
Highlighted
Nore_1
Regular Collector

UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

When I active the UCMDBtoSCSM-Job appears this error:

<< Mensaje de progreso, Gravedad: Fatal>>
Probe wasn't found. Task for Trigger CI will not be created.

What could be wrong?

Thanks!

Note: Integration UCMDB 7.5 to SM 7.01, with UCMDB7-SCSM.zip package.

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator

7 REPLIES
Amit Bandekar
Honored Contributor
Solution

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Make sure the probe name is added in the Trigger TQL's section.

--Amit
Nore_1
Regular Collector

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Thanks Amit!

I check the Job Configuration at Discovery and I forced to use the Probe Server I wanted. Maybe it doesn't get the Default Probe. And the error disappears.

Now.. I'm getting a new one :S


<< Mensaje de progreso, Gravedad: Error>>
Traceback (innermost last):
File "UCMDBtoSCSM", line 27, in ?
ImportError: no module named SMIntegrationAPI

Any Idea?


Thank you.
Dmitry Shevchenko
HPE Expert

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Did you add a path to wrapper.jar file at the beginning of COMMON_CLASSPATH entry in wrapperEnv.conf on the probe machine?
Nore_1
Regular Collector

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Yes Dmitri, I really did it. And then I restart the Probe (HP DDM->DDM Probe).
Check the attachtment...
I checked the path on the server and it's the same.
Are there something wrong on it?

Thanks!
Gretar_Palsson
Collector

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Hi

I got the following from HP support regarding this:

Stop your probe, then open the wrapper.jar you currently have on your discovery probe both probeManager and probeGateway using winrar and replace the existing SMIntegrationAPI*.class with the ones in the provided zip, then restart your probe

1. Go to Admin -> Platform -> Users and Permissions
2. Add a new user (use mode "Operational") (t.d. smintegration með yggdrasill lykilorðið)
3. Once user is created, select user and on the right switch to "Permissions" tab
4. There is a drop-down box to Select context, switch to UCMDB WS API, then select the "cmdb.open_api" in the tree
5. On the right under "Predefined Roles", select all the Cmdb* roles
6. At the bottom push "Apply Permission", then try to access that URL again and I think it will work
7. In the jython script UCMDBtoSCSM.py, you need to add two new arguments to the initialization of the SMIntegrationAPI, the user and password as strings:
api = SMIntegrationAPI("ucmdb2sc",ip, port, "username", "password")

I have attached the SMIntegrationAPI.zip which includes the classes you need. This worked for me and I hope it works for you.

regards
Gretar
Amit Bandekar
Honored Contributor

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Gretar is right. We had followed the same steps to get it working.

--Amit
Adina
Super Collector

Re: UCMDBtoSCSMJob error (Integration UCMDB 7.5 to SM 7.01)

Hi,

I want to integrate uCMDb with SM, but I can't get the data.xml running the UCMDBtoSCSM job.

I added the SMIntegrationAPI class in the wrapper and I modified the WrapperEnv.conf to point to the wrapper.

The function api.queryByName("data") doesn't return anything.

Any ideas?

Thanks a lot,
Adina
//Add this to "OnDomLoad" event