The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
UCMDB and UD Practitioners Forum (Previously CMS)
cancel
Showing results for 
Search instead for 
Did you mean: 

UCMDB Installation Issue

Highlighted
RJO
Occasional Contributor

UCMDB Installation Issue

Hi,

I am just learning to install the applications as of now, so please pardon me in case I am missing the obvious.

I have an issue installing UCMDB (7.5.2) on my desktop. All seemed well until doing the configuration for UCMDB.
After entering Foundation MS SQL Settings, I get an error Operation Failed. See Logs for more details.

Can any one help me with a thread / article for troubleshooting.

I am afraid I am not sure of the logs referred to here, but the SQL Server Logs seems to suggest has repeated entries of the following Line
"2009-05-29 12:50:13.22 spid71 Starting up database 'UCMDB'.

Environment Details
Win XP
MS SQL 2005
UCMDB 7.5.2

Thanks in advance
Raj

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp forum moderator

8 REPLIES
Alexander Arkhi
Honored Contributor

Re: UCMDB Installation Issue

Please supply:
\UCMDB\UCMDBServer\j2f\log\configserver\configserver_all.log

Also, mention what is the flow of installation (7.5 -> 7.5.1 -> 7.5.2 or anything else)?
Did you instruct Configuration Wizard to "Create New Foundation Database"?
Does the user you provide to Configuration Wizard have all necessary permissions (e.g. "sa" for MS SQL)?
RJO
Occasional Contributor

Re: UCMDB Installation Issue

Hi,
Attached the file.
1. The flow of installation :( I installed 7.10 directly on my desktop.
2. Yes, I instructed Configuration Wizard to "Create New Foundation Database"?
3. I used sa.
Thanks for your help.
Alexander Arkhi
Honored Contributor

Re: UCMDB Installation Issue

My suggestion is:
* Run "Connect to DB"
* Make sure you input proper DB Server settings (IP, username, password)
* Create new Foundation + CMDB + History Schemas

It looks like first time you tried to connect to localhost instead of DB server.
Also make sure that your Foundation, CMDB & History Schemas have different names (e.g. ucmdb_fnd, ucmdb_cmdb, ucmdb_hist)
Yossi Zaaroor
Frequent Visitor

Re: UCMDB Installation Issue


from the logs the problem is that the database cannot be connected to using TCP port 1433.

is the MS-SQL database installed on you desktop?

if so, just make sure it's TCP (default port 1433) is active.

by default TCP connections are not allowed.

Also, might be the windows/personal/any firewall you have on the desktop blocks the connection.


Yossi
RJO
Occasional Contributor

Re: UCMDB Installation Issue

Hi,
Thank you for your inputs Alexander and Yossi.

Sorry that I did not mention , I an trying to connect to the db on my local desktop and I presume that the installer connects well, since it is able to create a UCMDB db

I did not have the option to provide names for Foundation, CMDB & History Schemas. Can you please ellaborate ?
Alexander Arkhi
Honored Contributor

Re: UCMDB Installation Issue

Pre-requisite: UCMDB is fully stopped
You should:
* Start -> Programs -> HP UCMDB -> Connect to Database
Select "Create new database schemas"
Then follow the wizard providing different names for all 3 schemas.

Also, note that MS Windows XP is not supported platform for UCMDB, so I'd suggest to install uCMDB on a Server OS (e.g. MS W2k3) and start from there.

Regards,
Alex.
Stanislav Makar
Acclaimed Contributor

Re: UCMDB Installation Issue

As I can see there might be a problem with Domain Manager (Sonic Bus component).
Do you have Symantec (or any other) antivirus installed on your system?

Could you please attach Domain Manager logs?
Stanislav Makar
Acclaimed Contributor

Re: UCMDB Installation Issue

Also I suggest you not to use 'localhost' but to put FQDN of MSSQL server
//Add this to "OnDomLoad" event