The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
UCMDB and UD Practitioners Forum (Previously CMS)
cancel
Showing results for 
Search instead for 
Did you mean: 

UCMDB: Error when retrieving objects using TQL

Highlighted
Praveen_Shan
Collector

UCMDB: Error when retrieving objects using TQL

Hi Everyone,

 

Version: UD 10.1

 

I'm not able to retrieve the results when I query a TQL. I would appreciate if you could help me figure out the setting that I need to change to increase the "Maximum allowed limit".

 

Thanks,

Praveen

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. -HP Forum Moderator

3 REPLIES
Praveen_Shan
Collector

Re: UCMDB: Error when retrieving objects using TQL

Please find the attached error screen shot.

PuneetS
Frequent Visitor

Re: UCMDB: Error when retrieving objects using TQL

Hi Praaveen,

 

Did you check in Infrastructure Settings Manager, if you have some relevant setting there?

 

Anyways here is what I did for version 8.06, don't know if this is still relevant:

 

To solve this please go to the path C:\hp\UCMDB\UCMDBServer\j2f\conf\settings, and open the cmdb.xml file, please backup this file. At line 385 you will find the setting: 

 setting name="tql.max.ci.flayout.allowed" 
sectionResource="section.tql" 
 refreshRate="Reboot" 
displayInUI="false" 
 nameResource="tql.max.ci.flayout.allowed.name
descResource="tql.max.ci.flayout.allowed.desc" 
 settingType="customer"> 
<value type="number">300000</value> 
 </setting> 
 
Please increase the value <value type="number">300000</value> to <value type="number">400000</value>. 
 Then go to the line 1260 and increase the setting: 
 
setting name="tql.max.result.size.layout.retrieval" 
 sectionResource="section.tql" 
refreshRate="Reboot" 
 displayInUI="false" 
nameResource="tql.max.result.size.layout.retrieval.name
 descResource="tql.max.result.size.layout.retrieval.desc" 
settingType="customer"> 
 <value type="number">200000</value> 
</setting> 

 From <value type="number">200000</value> to <value type="number">400000</value>. 
 
 

Regards
Puneet

If you find this reply helpful, Click the KUDOS button on the bottom to say 'Thanks'
Praveen_Shan
Collector

Re: UCMDB: Error when retrieving objects using TQL

Hi Puneet,

 

Thanks very much for responding to this post.

 

I did check the Infrastructure settings Manager but was not able to find a specific setting with the value 2000000.

 

We've been using UD10 for all our discovery and modelling purposes. I like what you did on version 8.06 (C:\hp\UCMDB\UCMDBServer\j2f\conf\settings) but I'm still figuring out where the same file is on version 10. There is no folder called j2f in the new version. If you get to know, please keep me posted. Meanwhile, I'll check with HP support for a possible answer.

 

Thanks again,

Praveen

 

 

 

 

//Add this to "OnDomLoad" event