UCMDB and UD Practitioners Forum (Previously CMS)
cancel

NetApp Filer Discovery Error

Highlighted
churchie73
Occasional Contributor

NetApp Filer Discovery Error

Has anyone seen this error regarding the NetApp Filer discovery?

"NaAPIFailedException: netapp.manage.NaAPIFailedException: Unable to find API: system-get-info (errno=13005)"

I am thinking it might be due to permissions on the filer but wanted to bounce this around here before meeting with our storage team.

9 REPLIES
Rey_L
Frequent Visitor

Re: NetApp Filer Discovery Error

 

Spoiler
 

system-get-info is a command
Was the command login-http-admin successful in your communication log

 

Verify the discovery credential can run the following commands:

login-http-admin
Required permission for the discovery. You cannot authenticate or login to a NetApp Filer using the Netapp WebServices API without it.

api-system-get-info
Get appliance details including CPU and backplane information. (Head information in a sysconfig -a command). I/O information is not included.

api-system-get-ontapi-version
Required to Get current ONTAPI major and minor versions.

api-ipspace-list-info
Get information about ipspaces including IP addresses and relevant IP details. (Requires vfiler license.)

options-get G
et values for optional parameters.


api-volume-list-info-iter-start
api-volume-list-info-iter-next
api-volume-list-info-iter-end
Get details on volumes in the appliance.

api-snapshot-list-info
Get details on snapshots for a specified volume.

api-snapvault-<SnapvaultLevel>-relationship-status-list-iter-start
api-snapvault-<SnapvaultLevel>-relationship-status-list-iter-next
Get snapvault details from the appliance.
<SnapvaultLevel> can be either primary or secondary or both of these.

api-cifs-share-list-iter-start
api-cifs-share-list-iter-next
api-cifs-share-list-iter-end
Get details on CIFS shares on this appliance. (Requires cifs license.)

api-cifs-session-list-iter-start
api-cifs-session-list-iter-next
api-cifs-session-list-iter-end
Get details on CIFS sessions on this appliance. (Requires cifs license.)

api-nfs-exportfs-list-rules
Get details on NFS shares on this appliance.

api-security-api-vfiler
api-nfs-exportfs-list-rules-2
Get details on vFilers.

api-system-cli
api-cli-ifconfig
Get details on network interfaces.

 

Rey Lejano

effectualsystems.com
churchie73
Occasional Contributor

Re: NetApp Filer Discovery Error

Rey,

 

Fir off, thank you for your reply. I've been playing with this job for the past week. I have full access to the filer in our test environment. I've verified my credentials connect successfully in the Dataflow Probe Setup.

Looking at the Debug->View Communication Log file I dont see any reference to the login-http-admin command. There may be another logfile i can look at but i'm not sure what that logfile would be. How would I test the login-http-admin command?

This is the Comm Log file i get when i run the job.

"<execution jobId="NetApp Filer by WebServices" destinationid="4ca5a6bee489a361a63a86fd3ef16e93" max_store_sent_results="2147483647">
 <destination>
  <destinationData name="ip_domain">DefaultDomain</destinationData>
  <destinationData name="hostId"></destinationData>
  <destinationData name="id">4ca5a6bee489a361a63a86fd3ef16e93</destinationData>
  <destinationData name="ip_address">172.30.99.14</destinationData>
 </destination>
 <params>
  <param param_name="JOB_ID" param_value="NetApp Filer by WebServices" />
  <param param_name="taskType" param_value="runNow" />
  <param param_name="getSnapVaultInfo" param_value="false" />
  <param param_name="chunkSize" param_value="1000" />
  <param param_name="maxThreadRuntime" param_value="900000" />
  <param param_name="getNetworkShareInfo" param_value="false" />
  <param param_name="getSnapShotInfo" param_value="false" />
  <param param_name="filerOptions" param_value="nfs.tcp.recvwindowsize" />
 </params>
 <log start="14:24:16" severity="info">Execution current time:2016/04/11 14:24:16</log>
 <log start="14:24:16" severity="warn">[netapp_webservice_utils.py:wsInvoke] Exception: &lt;
Traceback (most recent call last):
  File "netapp_webservice_utils", line 177, in wsInvoke
NaAPIFailedException: netapp.manage.NaAPIFailedException: Unable to find API: system-get-info (errno=13005)
&gt;</log>
 <log start="14:24:16" severity="debug">netapp: Internal error. Details: Error retrieving system details from FILER</log>
 <log start="14:24:16" severity="debug">Reporting error code 103 to framework.</log>
 <log start="14:24:16" severity="debug">Error message is: netapp: Internal error. Details: Error retrieving system details from FILER</log>
 <log start="14:24:16" severity="info">Execution current time:2016/04/11 14:24:16</log>
</execution>"

Any help is greatly appreciated!

Rey_L
Frequent Visitor

Re: NetApp Filer Discovery Error

Keep in mind the Check Credential uses a different adapter and scripts

Check for version compatability, the 10.21 doc states: This discovery supports NetApp Data ONTAP 7.2.x, 7.3.x, 8.x with installed ONTAP SDK 3.5.1, and 8.x with installed ONTAP SDK 5.3.1.

Also from the documentation:

The NetApp Filer by WebServices job does not identify vFilers. All of the vFilers resources are connected
to the 'root' NetApp Filer.

Rey Lejano

effectualsystems.com
churchie73
Occasional Contributor

Re: NetApp Filer Discovery Error

What I am seeing from the NetApp Manageability SDK for the version of DATA ONTAP 8.X that we use is that 'system-get-info' is not a supported command in this version or any of the several previous verisons. I am able to see the ontapi version being reported as 1.31 from the script so I know the system is responding to the first few SOAP calls. Looking into this is nearly impossible on NetApps site which is extremely difficult to find help. The API calls appear to have been "updated?" and with the NetApp Filer scripts being used in uCMDB created back in 2010, I think there must be an udated set of routines to access the appropriate methods and calls for this job to work. I will bring this up in the practitioners forum but any other ideas i can try inthe meantime would be greatly appreciated.

SivaBoppana
Occasional Contributor

Re: NetApp Filer Discovery Error

Hi,

Did you find any solution to the issue.

We are trying to discover Netapp Filers in our environment. But Filers doest have SDK installed on them. Is it mandatory to have ONTAP SDK installed on filers? If yes is there any help document on the ONTAP SDK installtion and Web Services API would be greatly helpful.

Or Is there any alternative solution to have netfiler discovered in CMDB.

UCMDB version: 10.22 CP19

Netapp Filer version - 8.x

Thanks In advance.

 

 

 

 

 

churchie73
Occasional Contributor

Re: NetApp Filer Discovery Error

No sulution as of yet.
The issue I am seeing is related to the version of the ONTAP software that our Filers are running, 8.3.1 I believe. This verison of ONTAP does not work with the current NetApp Filer discovery job as it exists in uCMDB. I suspect that previous versions of ONTAP are working just fine with this job,

I have a ticket open with NetApp support to hopefully determine how we can modify the current script to work with this verison of ONTAP.
As for the NetApp Manageability SDK, use the following link to pull your verison of the SDK.
https://mysupport.netapp.com/documentation/productlibrary/index.html?productID=60427
Note if you need earlier versions of their SDKs there is a link off to the side for archived documentation.

I am not an expert at all when it comes to Filers, but I do believe you will need to have the ONTAP SDK installed to access the API calls on the Filer.
Good Luck,

Darren

SivaBoppana
Occasional Contributor

Re: NetApp Filer Discovery Error

Hi Darren,

Thanks for your reply.

i too dont have good knowledge on storage. I am just trying to understand if ONTAP SDK has to be isntalled on the filers itself. As storage team here confirmed that they dont have SDK on the filer and they may not be able to install one as they use Command Line.

So i am trying to understand if we can copy manageontap-5.4P1  jar file to the probe manager path  like we do for vmware discovery.

Any idea on how your storage team setup SDK and web services and what privileges are provided.

Thank You.

Siva B

 

 

 

churchie73
Occasional Contributor

Re: NetApp Filer Discovery Error

Hi Siva,

Sorry to let this go by so long.
The way I understand it, there needs to be the installed OnTap API on the filers which should show up on the files as a directory named OnTap. If your filer team doesnt have this ( i think it is standard as part of the OS) I'm not sure why they wouldnt install it. It is essentially communicating through SOAP calls. The filer needs to have permissions set for the discovery which is of course coordinated between you and the filer team.

The hurdle I ran into is the new version of DataOntap OS that the newer filers have is incompatible with the current script provided by uCMDB. That being said, a CP is about to be released later this month (July) that should address the newer Ontap version and API.

If everything goes well, you should be able to setup the permissions, install the soon to be released CP, and configure your discovery job.

I will try to update this thread with my results in early August.

Hope this helps.

Darren C

SivaBoppana
Occasional Contributor

Re: NetApp Filer Discovery Error

Hi Darren

Thanks for your reply. I was able to discover netapp filers after copying the ONTAP SDK to the discovery resources and storage team setting up the necessary credentials.

But the C-mode netapp filers were still a challenge due to outdated discovery scripts. And as you are saying if next CP could help us with this that would be great.

Regards

Siva B

 

//Add this to "OnDomLoad" event