UCMDB and UD Practitioners Forum (Previously CMS)
cancel

Help with RTSM to CMS Integration and vice versa

Highlighted
Ben.Shirley
Outstanding Contributor.

Help with RTSM to CMS Integration and vice versa

 

We have configured this integration, however the results are unexpected. We were expecting just the CI's and CI relationships defined in the integration TQL to be replicated however other unwanted CI's are synced. This was noted here:-

 

http://h30499.www3.hp.com/t5/Application-Perf-Mgmt-BAC-BSM/Problem-with-RTSM-9-13-sync-to-CMS-9-05/td-p/5770071#.UHVj_k2ccuM

 

Is anyone in this forum able to assist?

 

5 REPLIES
b_bravi
Outstanding Contributor.

Re: Help with RTSM to CMS Integration and vice versa

what kind of other CIs it is replicated ?

 

IT should replciate the CIs which are part of the integration tql.

Ben.Shirley
Outstanding Contributor.

Re: Help with RTSM to CMS Integration and vice versa

We had a Business Service CI type related to a custom 'Maintenance Window' CI type, this TQL resulted count's of around 30 CI's for each, and then the relationship, however where we ran the integration, we had lots of other CI's sent across including Windows CI's and the total count was around 150 CI's. 

 

Adrian_David
Outstanding Contributor.

Re: Help with RTSM to CMS Integration and vice versa

Hello,

 

You can try to go tot the adapter xml and comment out the line:

 

<automatically-complete-reconciliation-info />

 

The reason for why you see those extra CIs is because they are needed for reconciliation.

 

Regards,

Adrian

Ben.Shirley
Outstanding Contributor.

Re: Help with RTSM to CMS Integration and vice versa

Hi, this was suggested by Dmitry, and and did do this but got the same results....

 

<full-population-days-interval>7</full-population-days-interval>
<!--<automatically-complete-reconciliation-info />-->
<adapter-settings>
<adapter-setting name="reconciliation.tql.depth">20</adapter-setting>
</adapter-settings>

b_bravi
Outstanding Contributor.

Re: Help with RTSM to CMS Integration and vice versa

could you use

automatically-complete-reconciliation-info=false

 

May be by default it is getting all the info considering true as the above value.