UCMDB and UD Practitioners Forum (Previously CMS)
cancel

Domain Scope Documentation....

SOLVED
Go to solution
Highlighted
yngvi thorfinns
Regular Collector

Domain Scope Documentation....

Hi,
I've got a strange error when installing a DDM probe. The install finishes with this error:
'Domain Scope Documentation not available.....'
I've a license 'advanced_ucmdb_license.xml'
installed.

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. -HP Forum Moderator

28 REPLIES
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

Can you elaborate what you mean when you say that you "installed" the license file?

--Amit
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

I did 'supply' the xml file, while installing the uCMDB, into some specified path.
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

Try by renaming the 'advanced_ucmdb_license.xml' to just 'ucmdb_license.xml' and doing a reinstall.

--Amit

yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Do you mean, I have to uninstall / install the uCMDB again?
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

If you say that an error occured during the install, it is advisable to re-install.

--Amit
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Sorry, maybe I did state this clearly.
- I did not have error while installing the uCMDB.
- The error occurs on the ddm probe server, while installing the probe.
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

Hmm..then it is not a license issue. Are you able to ping from the DDM probe to UCMDB? Is the probe behind a firewall?

--Amit
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

The probe server and the uCMDB server are located on the same subnet.
Yes the ping is OK.
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

- Whats the version?
- Is this a new install or un upgrade?
- Are other probes facing the same issue or only this one?
- Within the uCMDB IP range fields, is there any entry which has no range specified i.e standalone IP?

--Amit
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

- I did a fresh install 8.00 then installed patches 8.01 and 8.02.
The OS is windows 2003 server, SP2.
- I've only tried to install this probe
- The ip range for the Probe, is this range:
xxx.xxx.xxx.26 - xxx.xxx.xxx.41
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

How can I verify within the uCMDB if the license is OK?
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

Is this standalone UCMDB or integrated to BAC?

Go to http://:8080/jmx-console
Under MAM, click service=UCMDB UI
Locate getLicenseForCustomer(), in the force parameter box, select FALSE.

For parameter customerId, enter 1.

Click Invoke. This should display the license type.


--Amit
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

Also, I would advise you to verify the DDM probe install on another machine (maybe your PC) just for trouble shooting purpose.

--Amit
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

The setup is a standalone uCMDB.
Note the uCMDB server is running on VMWare vers. ESX 3.5.0 with Gig interfaces (as recomended in HP documents). The DB datafiles are on a seperate DB system, which is not VMware.

The license output is like this:

License type: ADVANCED
Customer Name: Advanced UCMDB customer
Permitted packages: all
Blocked applications: none
Amit Bandekar
Honored Contributor

Re: Domain Scope Documentation....

The license has installed correctly.

The primary issue is that for some reason the probe is unable to get the Domain Scope Document XML from UCMDB. That is why I am asking you to install the probe temporarily on another machine to confirm if you seeing the issue only on one machine or regardless of machine.

--Amit
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Ok, I'll be able to do this experment tomorow.
Thanks!
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

I can add to this now.
As we have two platforms (DEV) and (PROD) this probe server has been tested on the (DEV) platform. We could install probe succesfully when we connected this server on the (DEV) subnet.
Then we uninstalled the probe, moved the server to the (PROD) subnet. After creating our new (PROD) platform, I tried to install the probe, but it's not succesful yet, as I've described. According to this, the probe server is OK.
Dmitry Shevchenko
HPE Expert

Re: Domain Scope Documentation....

Are both uCMDB server and DDM probe of the exact same version? For example, both 8.02?
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Yes, I'm running this install script on the probe server:

'HPDiscoveryProbe_v802_win32.exe'
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

there are two 'services' on the probe server:
DDM_Probe
DDM_Probe_DB

The DDM_Probe is not started (manual setting)
but the
DDM_Probe_DB is stared (automatic setting)

Does this matter?
Dmitry Shevchenko
HPE Expert
Solution

Re: Domain Scope Documentation....

Yes, it matters. DDM_Probe service must be started as it's actually the DDM probe itself.
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Ok right. But it's not starting becuase of the 'Domain Scope Documentation...' error ?

I mean, it's not any good if I would start it myself manually?
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Well I did start this service manually.
It did start, so I altered the properties to 'autmatic'. I'll do some tests to verify.
yngvi thorfinns
Regular Collector

Re: Domain Scope Documentation....

Hi
I did install the DDM probe on a different probe server.
The result was the same as before, when I try to start the DDM Probe service, it comes with this error:
'Domain Scope Documentation not available.....'
//Add this to "OnDomLoad" event