The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
UCMDB and UD Practitioners Forum (Previously CMS)
cancel
Showing results for 
Search instead for 
Did you mean: 

DDm/uCMDB 8.0 issue - ssh to discover Unix servers not working due to AD authentication on Unix

Highlighted
Andy S
Super Collector

DDm/uCMDB 8.0 issue - ssh to discover Unix servers not working due to AD authentication on Unix

We have DDM/uCMDB 8.0 server installed on a windows server. Another windows server is configured as a DDM probe. We are trying to discover Unix servers using this probe via ssh protocol.

Since Unix servers use Active Directory based authentication and not /etc/passwd (or PAM) based authentication, the DDM cannot connect to these Unix target hosts via ssh.
Can anyone help resolve this issue?
Thanks

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator

3 REPLIES
Alexander Arkhi
Honored Contributor

Re: DDm/uCMDB 8.0 issue - ssh to discover Unix servers not working due to AD authentication on Unix

How do you (if that's possible at all) connect to those boxes via Putty (or any other client)?

If you will describe how the connection itself can be done, we'll try to assist you in getting SSH boxes discovered by DDM.

Regards,
Alex.
Andy S
Super Collector

Re: DDm/uCMDB 8.0 issue - ssh to discover Unix servers not working due to AD authentication on Unix

To test whether credentials are working, I first log on to a local Unix box (authentication via /etc/paswd on this box). From this box I issue the command
ssh

It asks me for user id and AD passwd
I enter these and then I am successfully logged in.

However when I try to check ssh protocol credentials through DDM, I get an error.

Alexander Arkhi
Honored Contributor

Re: DDm/uCMDB 8.0 issue - ssh to discover Unix servers not working due to AD authentication on Unix

Which kind of error do you get?
Can you, please, give a stacktrace.

Also, there might be a problem due to "specific" login/password prompt.
//Add this to "OnDomLoad" event