UCMDB and UD Practitioners Forum (Previously CMS)
cancel

Class model problem

Highlighted
SilverV
Super Collector

Class model problem

Hi,

I just tried to import all my custom packages & resources to a fresh OOTB deployment to test how my jobs & scripts from 10.11 + CP15 would work with 10.22 + CP20
Deploying of said packages fails, as the classmodel in my 10.22 env is not like it is in my 10.11 production environment (missing columns, links etc). For reasons unknown, I cannot import the model from 10.11 to 10.22:

Caused by: [ERROR CODE- 0] appilog.common.system.types.packaging.PackageException: Failed to install resource :
at appilog.server.packaging.cmdb.deployer.ClassModelPackageDeployer.installResource(ClassModelPackageDeployer.java:107)
..........
Caused by: java.lang.ClassCastException: com.hp.ucmdb.classmodel.binding.classes.XmlClassModel cannot be cast to com.hp.ucmdb.classmodel.binding.classes.XmlClass

I have reported this to HP support, but sometimes I get a more accurate answer from this forum.
Also, how can the classmodel be maintained if each upgrade makes changes to the classmodel? What I mean is - if I import a classmodel from 10.11 to a considerably newer 10.22, then wouldn't it overwrite some changes that come with 10.22?

Thanks in advance.

5 REPLIES
SilverV
Super Collector

Re: Class model problem

Anyone?

J-kalibre
Acclaimed Contributor

Re: Class model problem

I had the same issue when trying to upload an RTSM Package via the GUI in 10.11. But it still works using the opr-jmxClient tool

C:\HPBSM\opr\support>opr-jmxClient -system %hostname%:29612 -user %user% -password %password% -b "UCMDB:service=Packaging Services" -m deployPackages -a 1 %package_directory% %package_name% true true

@SilverV have you heard back from support yet?

SilverV
Super Collector

Re: Class model problem

I'm beginning to think that the output of exportClassModel is not intended to be imported via the CI Manager in GUI. It doesn't actually say this anywhere in the documentation. This is problematic, since in the package manager you can't check all sub classes by checking the root class. For example, if I check Configuration Item class in package manager, it doesn't check the subclasses - meaning that I have to check each class by hand. This also needs to be done when a new class is created. There are hundreds of classes, so creating any backup for the class model is error-prone to say the least. I've tested this in 10.11, 10.20 and 10.22 - it behaves like this in all of them.

Support has not been exactly helpful...

By the way, exporting/importing CI's one by one via the GUI is extremely difficult also. Our BSM is so old that import into BSM fails, creating a lot of manual overhead.

Essentially I want to back up my class model without clicking through hundreds of CI's by hand. I can't understand how this is so difficult to explain to people, especially the support. Am I overlooking something really simple here?

Strawberry1
Super Collector

Re: Class model problem

Hi, 

Did you check the log files. When there is an issue it writes the issue into one of the many log files. 

for example:

  • error.log
  • mam.packaging.log
  • cmdb.classmodel.*

Good luck

SilverV
Super Collector

Re: Class model problem

2016-07-20 16:05:18,864 ERROR [qtp1626845080-6267] - <Customer <1, id name: Default Client>Failed to deploy resource [class/], error is: Failed to install resource :
[ERROR CODE- 0] appilog.common.system.types.packaging.PackageException: Failed to install resource :

//Add this to "OnDomLoad" event