Systinet Practitioners Forum

Cant Access HP SOA Remotely Redirects to Localhost

Go to solution
Respected Contributor.

Cant Access HP SOA Remotely Redirects to Localhost


I have installed SOA 3.20 successfully and can access the URL fine from the VM Server (localhost) where it is installed. When i try to access it from my local machine it redirects me to localhost and give me a unable to connect to localhost error. Is there a way to change the redirect to point to the Host Name and not localhost? Here is the message i am seeing in the output

18:49:31,197 INFO [LoginServlet] Redirecting to http://localhost:8080/soa/web/service-catalog/

As you can probably tell i am new to SOA, so any help is greatly appreciated.
Tomas Kulhanek
Super Contributor.

Re: Cant Access HP SOA Remotely Redirects to Localhost


the SOA Systinet uses the configuration settings reffering to the hostname to render HTML pages.
The easy way to reconfigure your SOA instance is to change the hostname using setup tool:

1. stop the server (if you use JBoss app. server you may do it by pressing Ctrl+C on the server console, or execute the [SOA_HOME]/bin/serverstop.bat)

2. launch the setup tool
[SOA_HOME]/bin/setup.bat Advanced and in the list of "Custom Scenario Selection" select "Endpoint Properties". The other depended scenarios will be selected automatically.

4. Into the "Hostname" field enter the fully gualified hostname or e.g. IP address (instead of localhost) under which is your application server listening the incoming HTTP connection and you whish this hostname(or IP) will be rendered into the HTML.

5. Next, Next, Finish, if you don't use JBoss app. server you may need to redeploy the ear.

6. start the server

Let me know whether the advice helped you.


Tomas Kulhanek
HP SOA Systinet Support
Respected Contributor.

Re: Cant Access HP SOA Remotely Redirects to Localhost

Thomas had the perfect answer to solve this problem. After making the changes recommended i was able to access the application without any issues from a remote pc. See thread above for details of resolution. Thanks for the Help and great answer!