Storage Essentials Practitioners Forum
cancel

SE 6.3 Opening console error

Highlighted
G Swart
Valued Contributor.

SE 6.3 Opening console error

Hi,

 

Im trying to install and configure SRM 6.3 onto a server without having any luck. The following was done.

 

  1. Installed SRM and Oracle DB on Windows 2008 SP2 and did all the pre installation modifications as per documentation.
  2. Installation passes but have ORA-00604 and ORQ-01882 error's in the logs.

When I try to open the console by http://1.1.1.1, I get  a "HTTP Status 500-" error on IE.

 

Has anyone got a solution or encountered something like this before? I did try and install this on 2 different servers with the same result.

9 REPLIES
WileyThrasher
Super Contributor.

Re: SE 6.3 Opening console error

Hi,

 

Can you confirm a few details:

 

1) Is this a single shared server, or the recommended dual server configuration with SE on one box, SE Reporter (RD/RO) on another?

 

2) Is it possible the server is running Windows 2008-64 R2? (R2 is currently unsupported).

 

3) Were there any errors or messages in the installation logs (can use the srmcapture tool to gather them)?

 

4) Anything else regarding the server configuration, such a multi-homed network configuration, or had a previous installation of Oracle?

 

5) Was it installed from physical media (screen printed HP CD/DVD disks), or from ISO images? If ISO images, were their MD5 checksums verified prior to mounting on the destination server? (suggested to verify, then mount directly, as problems typically with corrupt ISOs, extracted media (copied from the disks).

 

6) Opening a support case might be warranted, however, since the product is not customer installable and requires a services engagement, you may have limited options to engage support... (depends on the context of this install, if a partner, for a POC/eval, we may have alternatives).

Wiley Thrasher
Storage Management Expert
HP Storage TCE and Quality Tiger Team
WW L3 Pre-sales Support
Hewlett-Packard Company
G Swart
Valued Contributor.

Re: SE 6.3 Opening console error

Hi Wiley,

 

  1. Just SE on one box. No reporter licenses. (Single server)
  2. Windows 2008 Enterprise (Not R2)
  3. Where can I mail the log files to?
  4. Clean install on 2 different boxes doing the same.
  5. No Multi homing.
  6. I got the DVD's from HP South Africa.

I did speak to a HP Software specialis and he said it might be the Oracle DB that needs patching. Whats your thoughts on this?

G Swart
Valued Contributor.

Re: SE 6.3 Opening console error

Sorry,

 

Just ignore point 3. Logs are attached.

WileyThrasher
Super Contributor.

Re: SE 6.3 Opening console error

Hi,

 

A few key points, observations and questions.

 

Regarding patches (for Oracle) we include and automatically patch our Oracle as part of the installation process.

 

In regard to SE Reporter (Report Database/Report Optimizer)... this is a required installation for all environments as it provides the base (built-in) limited read-only reporting capabilities for the product. The options are to install a single shared server with SE/RD/RO (and our databases), or dual servers SE on one server, and RD/RO on a second server with their respective databases. In regard to licenses, if you want the capability for custom (ad-hoc) report generation, you would purchase one or more Report Optimizer user licenses to apply to the base (included, and required) SE Reporter installation.

 

It would appear that you have less than the recommended RAM on the server... per the install wizard and 16GB is the minimum for the single shared server platform, 12GB each for dual servers.

 

Can you verify the region/localization settings for your OS, as I see many exceptions in the logs - quite likely the source of the issues:

 

  Exception while acquire connection to database: ORA-00604: error occurred at recursive SQL level 1
ORA-01882: timezone region  not found

java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
ORA-01882: timezone region  not found

 

==============================================================================
  Warnings found in: C:\srmInstallLogs\Srm_DatabaseSchema_Output.log
==============================================================================
Line Text
------------------------------------------------------------------------------
419:   Exception while acquire connection to database: ORA-00604: error occurred at recursive SQL level 1
420: ORA-01882: timezone region  not found
422: java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
423: ORA-01882: timezone region  not found
446: java.lang.NullPointerException
458: javax.ejb.EJBException: null; CausedByException is:
465: java.lang.NullPointerException
477: java.lang.NullPointerException
639:   Exception while acquire connection to database: ORA-00604: error occurred at recursive SQL level 1
640: ORA-01882: timezone region  not found
642: java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
643: ORA-01882: timezone region  not found
666: java.lang.NullPointerException
677: javax.ejb.EJBException: null; CausedByException is:
684: java.lang.NullPointerException
695: java.lang.NullPointerException
760:   Exception while acquire connection to database: ORA-00604: error occurred at recursive SQL level 1
761: ORA-01882: timezone region  not found
763: java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
764: ORA-01882: timezone region  not found
785: java.lang.Exception: Connection to database failed
791: java.lang.Exception: Connection to database failed

 

 

 

Wiley Thrasher
Storage Management Expert
HP Storage TCE and Quality Tiger Team
WW L3 Pre-sales Support
Hewlett-Packard Company
G Swart
Valued Contributor.

Re: SE 6.3 Opening console error

The regional settings is set to South- Africa. Is there anything else I should change.

 

The memory on the server is 12GB but this only a test server at the office and the server at the client does the same with 16GB memory installed.

 

Do I need the Reporter installed to get the SE console to work?

 

Sorry for all the questions, but I'm new to SE 6.3.

WileyThrasher
Super Contributor.

Re: SE 6.3 Opening console error

Hi,

 

Based on the errors seen, and subsequent failure... I'm guessing the region setting would be the most likely culprit. Might ask the local HP folks you work with what settings they have on their SE server and match theirs.

 

I continue to ask about the media, if it's physical disks, or ISO images, and the specifics of how it was mounted since we see a variety of issues due to corrupt software installers - so would be good to confirm the details to assure this is not the source of the failure.

 

As for memory, really depends on the expected use... Our specs are intended as minimums to assure that customers with medium to large environments (a subjective topic in itself - since there are at least 6 dimensions to factor) have sufficient system resources to support scalability and performance. 12GB is sufficient for installation - and would likely have no issues for a smaller environment.

 

Regarding SE and SE Reporter (Report Database/Report Optimizer)... It would all depend on what you consider "work"., since the key aspect of the product is it's reporting capabilities - I am unaware of any customer that would not need SE Reporter installed (and to restate it's a requirement). It's simply optional as to the location (single shared server, or dual dedicated servers), and if the customer wants ad-hoc custom report creation capabilities - to purchase a RO User license.

 

If you intent is to play with the product (assuming you have lab you will discover), or even to "experience" the typical installation and basic configuration process (without discovery beyond the SE CMS and our Oracle via the "Monitor Product Health" feature) it would be suggested to at minimum to install the complete product (SE/RD/RO) on the single server.

 

Our recommendation for medium or large environments is the dual server deploy, where you take the SE SRM, SE Oracle, and Report Optimizer disks and run the same setup.exe on the SE SRM disk to install RD/RO on a 2nd server - and then configure SE to point at the RD/RO server (via Configuration > Reports), and use the reportAdmin utility on the RD/RO server to add the SE CMS "source" to sync up data for viewing our many default OOB report templates in the SE Report Pack (and/or the process custom report creation).

 

Hope this helps,

 

Wiley-

Wiley Thrasher
Storage Management Expert
HP Storage TCE and Quality Tiger Team
WW L3 Pre-sales Support
Hewlett-Packard Company
G Swart
Valued Contributor.

Re: SE 6.3 Opening console error

I will open a call with HP South Africa to assist. Thanks for the reply.

G Swart
Valued Contributor.

Re: SE 6.3 Opening console error

Hi,

 

I received a Oracle Time Zone patch to fix the error I had. That took the error away but I'm stuck on the next page.

 

Please see if it looks familiar by any chance.

WileyThrasher
Super Contributor.

Re: SE 6.3 Opening console error

Without specific context, it's hard to suggest what issue you're experiencing.

 

Did you use the RemoveAll script to uninstall/cleanup the failed installation, reboot, and re-install? Or just patch and reboot the server? And was this a complete installation of Storage Essentials with the required Report Database and Report Optimizer on the same server?

Were you able to get to the login screen?

 

You could try to stop AppStorManager (SE's core service) and try to re-init the SE database via dbAdmin tool.

 

Wiley

Wiley Thrasher
Storage Management Expert
HP Storage TCE and Quality Tiger Team
WW L3 Pre-sales Support
Hewlett-Packard Company