Service Test Practitioners Forum

API tests Not Saving or Executing properly

New Member.

API tests Not Saving or Executing properly

I am using 11.52 build 0561 and have patches 01,22,37, and 56 installed. 


I have created a simple API test that submits a post  message and then validates the xml response. When I attempt to change the message in anyway, the changes appear in the screen, but do not execute. Changes have included changing the request body, or the lines & values to be validated in the response body. However whenever I execute the test it will validate on the older values and not include any updated information. I have tried changing the test on multiple machines with no luck. so if I change the test to include more checkpoints and they would normally fail, the test results actually show the test as succeeding. 


I have tried saving the file and then leaving UFT/QTp and getting back in only to find my changes saved in the gui but when executing the test, they do not take affect. Also tried re-compiling & cleaning the test and project. I checked the checkpoints.cs file within the test and that file does not seem to be updated with my latest checkpoints either.


I am using a database for paramaterization on the test but that does not seem to impact this issue and is working normally as this happens even on hardcoded variables. This has happened on multiple tests that I have created.


is this a known issue or is there any fix? Please help!