Service Manager / Service Center Practitioners Forum
cancel

Global List Display Null values in SM

SOLVED
Go to solution
SRIDHARDSV
Super Contributor.

Global List Display Null values in SM

Hi Experts,

 

I have created a new global list and rebuild the values to display in the form. When I logout and relogin to the Service Manager client ,global list value is null.

 

I did checked with RAD debugger to display value after relogin, it goes to Null.

 

If we rebuild the list , it is displaying the value and If I logout and relogin back  it is going to NULL again.

 

ANy help on this is highly appreciateably. Thank you

11 REPLIES
Piku
Acclaimed Contributor.

Re: Global List Display Null values in SM

have toy any dynamic query for same. if so, check what is return of this query.
also enable check box build on startup.

hth
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Luis_Alfaro
Outstanding Contributor.

Re: Global List Display Null values in SM

Hi,

 

When you check the global list record the "times updated" field is updated as well. Additionally, please let us know how many entries you have in that list. A unload could be helpful so, we can test it also.

 

Regards,

If you feel this was helpful please click the KUDOS! thumb below!
SRIDHARDSV
Super Contributor.

Re: Global List Display Null values in SM

Hi Experts,

Thanks for thr reply.

We have only two values in the Global list. I did verified the time updated field , it is updated when ever we do a change with the Global List.

build on startup has been enabled in the gl form.

Kindly let us know for further details. Thank you
Jacob Heubner
Acclaimed Contributor.

Re: Global List Display Null values in SM

Make sure the 'Use localized values' is unchecked, unless you have created scmessage records for each potential entry in your list.

 

The 'Use Localized Values' checkbox causes the system to check the scmessage table for value to display for the language of the operator and that entry in the scmessage record.

 

 

SRIDHARDSV
Super Contributor.

Re: Global List Display Null values in SM

Hi Experts,

 

Yes, 'Use Localized Values' is unchecked in my global list.

 

I have created global list with new list variable "$G.partners" and the values are like {"Sa","TR"}. I have rebuild the list as well. When I logout and re-login to the system, The combo box is not displaying the values in the form.

 

Help on this issue is highly appreciated. Thank you

Jacob Heubner
Acclaimed Contributor.

Re: Global List Display Null values in SM

If you use RAD Debugger, and display the variable, does it have values?  Is the issue that the variable has no values, or that it isn't working on the form?

 

Use RAD Debugger and type:

d $G.partners

 

is it displaying anything, or is it NULL or empty {}?

Highlighted
ZiggyPopp
Valued Contributor.

Re: Global List Display Null values in SM

When you want the list to be rebuilt on startup, you need to check the box and also need to rebuild the "startup" globallist so that it includes your new list.  Then when you logout and back in it should be there.

SRIDHARDSV
Super Contributor.

Re: Global List Display Null values in SM

Hi Experts,

 

Thanks for the reply. I did verified with the RAD debugger , when I am trying the command that is giving null value for the variable. If I rebuild the list and trying the display , variable showing the value. If logout and re-login back again I tried to display the variable value.. It is null again.

 

The variable doesn't have value in it , when I re-login to the system. Kindly let us know for further details.

Jacob Heubner
Acclaimed Contributor.

Re: Global List Display Null values in SM

Please show a screenshot of your global list record.

Michal_Kovac
Honored Contributor.

Re: Global List Display Null values in SM

rebuild gl named "Startup lists", then logout+login and check your gl (f.i. in RAD debugger)

Jas1
Acclaimed Contributor.
Solution

Re: Global List Display Null values in SM

To summarise, your globallist for $G.Partners is working. If it's disappearing after logout, there's a few possibilities.

1) You have not ticked the 'Build List on Startup' tick box of the new gl.

2) You may have forgotten to add the new $G.Partners globallist in the globallist named "Startup Lists", in it's value and display list fields.

3) your lister background process is not running.

 

It will also help us if you include screenshot of your new gl and the Startup List gl to help us help you.