Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

v_servicecalls view disappeared

SOLVED
Go to solution
Highlighted
Stephen Wood fr
Super Collector

v_servicecalls view disappeared

Hello,

I am running Openview Service Desk 5.1 with SP6.

I have noticed that we now do not have a view in SQL Views called v_servicecalls - it was there when we originally installed the system as I utilised it a lot for reporting (copy / pasting the SQL code out then using it in ASP web reports but the view isn't there now ... I am not sure when it vanished.

(We upgraded from SP2 to SP6 a couple of years ago.)

I have tried regenerating views which comes back OK but when checking in SQL Views again, it still isn't there.

Any ideas or if anyone else has experienced this (or if they can check their system if they run SP6) would be greatly appreciated.

Many thanks,


Steve.



3 REPLIES
The Pike
Honored Contributor

Re: v_servicecalls view disappeared

Steve,

That sounds kinda odd. I utilize those Views on a regular basis and never had problems.

Why not trace the database to see what goes on when Service Desk builds the Views?

The Pike
Ken Briscoe
Honored Contributor
Solution

Re: v_servicecalls view disappeared

This can happen if you have a custom field name which is also a SQL reserved word (eg "Select"). The log should show you the error then you just have to rename that custom field.

Check the log just after you regenerate the views, and check all your custom fields to see if one looks like a SQL field.
My email is kenilian@bigpond.com.au
Stephen Wood fr
Super Collector

Re: v_servicecalls view disappeared

Thanks very much chaps. Ken, you were spot on with the SQL reserved words issue - I had a custom field called TIME - now remaned and the regeneration of views now has brought back my Service Calls view.

Thanks again.

Steve.
//Add this to "OnDomLoad" event