Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

smart action/application command problem

Highlighted
Gail D
Collector

smart action/application command problem

I am trying to use the SC application to run a script. It works from a windows cmd line but not from the smart action.
Application is called "Unlocker.exe"
command line: unlocker.exe
start in: cd %ALLUSERSPROFILE%\Start Menu\Programs\hp OPenView service desk 4.5\client
I've related Unlocker.exe to a smart action. when I select the smart action from a SC ticket, I get "windows cannot find "Unlocker.exe". make sure you typed the name correctly, and then try again. I know the "tart in" path is correct otherwise the windows error would have return the path in the error.
Has anyone had this issue before or ideals on correcting?
(On SD4.5 SP17)
Thanks,
Gail
3 REPLIES
Gyula Matics_1
Honored Contributor

Re: smart action/application command problem

- It may not be able to resolve %ALLUSERPROFILE%. Try it with the full path.

- what kind of applicatin is unlocker.exe? is that a real .exe or just a script? if it is a script, then you can't just execute it. Instead, you have to run the interpreter.
Gail D
Collector

Re: smart action/application command problem

the full path will not fit in the "start in" field. I didn't write the script so I don't know what it was written in so I'll have to find out.
Gail D
Collector

Re: smart action/application command problem

I think the problem is with "ALLUSERSPROFILE" because if I copy the script to "C:\" and enter that in the "start in" area, the script runs.
I thought SD works with windows alias??
//Add this to "OnDomLoad" event