Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

sd_export error after migration to SP 15

SOLVED
Go to solution
Highlighted
David Waelder
Acclaimed Contributor

sd_export error after migration to SP 15

Hi!

After migrating to service pack 15, all batch processes I have for importing data into Service Desk are not working.

If I manually execute batch files I get the following error at the sd_export execution:
"ERROR: Failed to connect to server: username=adimport password=**** server
=bcnas18
You need to upgrade your software. Click the link below to go to the web page containing the latest version and patches."

I have already upgraded all components on the server (server, client, agent, integrations), so I do not know where else to look into.

Any ideas?
8 REPLIES
William_157
Senior Member

Re: sd_export error after migration to SP 15

Check this files:

Hewlett-Packard\Openview\service desk 4.5\server\lib\servicepack.jar

and chack if the date is same to the service pack 15.
David Waelder
Acclaimed Contributor

Re: sd_export error after migration to SP 15

Indeed!

Server file is from 8/10/2005 whether SP version is 1/28/2005.

Which one is the good one? Do I have to substitute one over the other?

Thanks for your reply.
William_157
Senior Member

Re: sd_export error after migration to SP 15

Delete the file and upgrade the saver again with the service pack.
David Waelder
Acclaimed Contributor

Re: sd_export error after migration to SP 15

Investigating further I have found that the client has not upgraded correctly (sd_version shows SP12) whether the server shows the correct version (SP15).

I have contacted my local support how can I safely upgrade the client since I've executed the service pack upgrade twice with no result (seems there's a bug upgrading on W2K SP1 servers).

Thanks for your help!
Michael Lutfi
Frequent Visitor

Re: sd_export error after migration to SP 15

David...here is a little trick that a few around know about....all you need to do to upgrade the client is delete the old servicepack.jar and replace is it with an updated servicepack.jar

And yes there is a major issue with the upgrade file most of the times. The upgrade file will execute and claim it did upgrade the client but then upgrade does not really happen.



HPRB
HPE Expert
Solution

Re: sd_export error after migration to SP 15

Hi David,

After upgrading to sp15 run the sd_version on the bin directory of server and client.

I see that your client didn't upgrade to sp15. Sometime there is corruption in the msi tool that leads to the files not upgrading in the lib directory of the server or/and client. This happens on windows machines. As a workaround, rename your servicepack.jar file on your client to servicepacksp12.jar and then run the upgrade of the client again. This will install the new servicepack.jar file for sp15. After the upgrade check the sd_version in the bin directory of the client.

Hope this helps.
RB
David Waelder
Acclaimed Contributor

Re: sd_export error after migration to SP 15

I've tested Rama's solution and it worked like a charm!

Thanks everybody for your support!
David Waelder
Acclaimed Contributor

Re: sd_export error after migration to SP 15

Renaming the "faulty" servicepack.jar file in the client /lib folder and reappling the service pack solved the issue.
//Add this to "OnDomLoad" event