The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

perl error when i execute sd_event (HPUX PARISC)

Highlighted
Saad Masood
Super Collector

perl error when i execute sd_event (HPUX PARISC)

hi everyone,

I have installed the SD_event package on my HPUX machine. it has the following perl packages installed:
# perl D.5.8.0.B Perl Programming Language
perl.Perl5 D.5.8.0.B Perl for HP-UX

when I try to use the "sd_event" on this machine i get the following error message:
Can't locate IO/Socket.pm in @INC (@INC contains: /opt/perl5/lib/5.00502/PA-RISC1.1
/opt/perl5
/lib/5.00502 /opt/perl5/lib/site_perl/5.005/PA-RISC1.1 /opt/perl5/lib/site_perl/5.005
.) at /opt/OV/sd/event/bin/sd_event line 380.
BEGIN failed--compilation aborted at /opt/OV/sd/event/bin/sd_event line 380.

I have searched for this "Socket.pm" on my machine with the "find" command, here is the output:

/opt/perl/lib/5.8.0/PA-RISC1.1-thread-multi/IO/Socket.pm
/opt/perl/lib/5.8.0/PA-RISC1.1-thread-multi/Socket.pm
/opt/perl/lib/site_perl/5.8.0/ActivePerl/DocTools/PSP/Socket.pm
/opt/hpws/apache/lib/perl/lib/site_perl/5.8.0/PA-RISC1.1-thread-multi/APR/Socket.pm

please tell me if i need to upgrade the Perl or need some path changes for that??

Regards
Saad Masood

//Add this to "OnDomLoad" event