The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

inactive sessions time-out

SOLVED
Go to solution
Highlighted
PatrikT
Regular Collector

inactive sessions time-out

Hi again,

we are working with SD4.5 SP20 on a HP-unix server.

We only have like 50 licenses but like 200 users ... Normally a session should be time-out after 30 minutes of idle time, but after moving the app to a new unix server this is not working anymore. Now users stay connected indefinite.

in the server_settings.xml I have copied below you can see some of these settings.


true
true
/opt/OV/sd/server/log/logserver.txt
true
6001
30
false
1000
10
1

Does any of you know where I can tweak or activate this again ?

thanks,
Patrik
5 REPLIES
The Pike
Honored Contributor

Re: inactive sessions time-out

The only time I have seen users stay connected indefinitely is when Automatic Refresh Interval is activated in the clients.

Points are welcome.

The Pike
PatrikT
Regular Collector

Re: inactive sessions time-out

Hi The Pike,

thanks for your answer.
as far as I am aware off, I have never altered this setting.
Nevertheless when changed in the console I think you need to restart the app-server to enable ?

Kind regards,
Patrik
The Pike
Honored Contributor
Solution

Re: inactive sessions time-out

The toggle to allow users to enable Automatic Refresh interval does not require the application server to be restarted.

Have you tried a controlled test of the timeout setting? I mean, monitoring a single session from the Logged on Users list and checking if after those ~30 minutes being idle the session is removed?

The Pike
PatrikT
Regular Collector

Re: inactive sessions time-out

I did a monitoring and was not completely convinced of working, but after restart all worked without a charm !
Thanks, The Pike !

Patrik
PatrikT
Regular Collector

Re: inactive sessions time-out

Golden suggestion, the Pike.
//Add this to "OnDomLoad" event