The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"

Highlighted
Moldovan
Occasional Advisor

hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"

Has anyone ran into this Microsoft ADO error using Service Desk?

After install when I try to run the app I get:

The follwing components are either not present on this machine or have an incorrect version number:
Microsoft ADO DB (Minimal required version: 2.1)
Please try to correct this problem first before starting the application.

I have XP Professional, Version 2002, SP 2

Thanks.
5 REPLIES
Mihai Tita
Occasional Visitor

Re: hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"

Hi,

Register msado15.dll. At command prompt type regsvr32 "C:\Program Files\Common Files\System\ado\msado15.dll"

Otherwise
Check for MDAC version:
1. The version information is found in the following key:
HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess\FullInstallVer
2. Use the Component Checker Tool from Microsoft

If you have some problems with MDAC try to diagnose and reconfigure MDAC installations. Please see the following link: http://support.microsoft.com/kb/307255

Regards,
Mihai
JaS_4
Honored Contributor

Re: hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"

If applying a new mdac does not work, you can try this trick.
Re-install the version that comes with Windows XP (which probably existed when it was working fine). Locate the file mdac.inf in the folder c:\windows\inf (this is a hidden folder).

Press the right mouse button while selecting the file mdac.inf, and select install. After installing, re-boot the machine. This should replace the existing MDAC with the appropriate one for the environment.
Ganesan Rajaiya
Acclaimed Contributor

Re: hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"

1. Install Java Virtual Machine from the below path

In the PC COE: k:\jre\jvm\msjavx86_3810_Full.exe


2. Launch the OVSD program installation:

If using PC COE: Launch AIM (select Install or Remove Applications from the Intelligent Desktop Assistant icon in your system tray), select Service Desk Suite from the list of applications (you may need to first File -> Enable -> K:\ServiceDesk\servicedesk.aim), and then select Install to start installation.

Then you would find the OVSD Installer in the Start-->Programs-->Hpopenviewservicedesk4.5-->OVSDINSTALLER

Select RAT OVSD and Click on Install. It would complete


3. Click the Windows Start button, type Run in the search box, and then when the Run pop-up window appears, type the following:

regsvr32 "C:\Program Files\Common Files\System\ado\msado15.dll"

You should then see a message that msado15.dll was successfully registered.

4. Try logging on to OVSD
Enter your Login name
Validate that Service Desk Server is set to obpsvd01.deasmi.co-lo.hp.com

5. If the service pack is the latest one please download the same which is pointed to and install the same.



Note: when connecting to OVSD the status bar goes to 80 to 85 percent and you see an error

com.ms.com.ComFailException: (0x80040154) Class not registered.

Some of the files are missing and it needs the latest service pack. You can download the latest service pack from the Microsoft site.

http://www.microsoft.com/downloads/details.aspx?FamilyID=B0C7136D-5EBB-413B-89C9-CB3D06D12674&displaylang=en

Installing the above service pack fixes the OVSD issue. But you will not get support from the IThelp desk if sp1 is installed. See the below link that says the same

http://ithelpcenter.corp.hp.com/1sw/GetIT/vista.htm

Ms-Office VBA
Steve Hood
Acclaimed Contributor

Re: hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"



"You can download the latest service pack from the Microsoft site.

http://www.microsoft.com/downloads/details.aspx?FamilyID=B0C7136D-5EBB-413B-89C9-CB3D06D12674&displaylang=en

Installing the above service pack fixes the OVSD issue. But you will not get support from the IThelp desk if sp1 is installed. See the below link that says the same

http://ithelpcenter.corp.hp.com/1sw/GetIT/vista.htm"

Thanks - the above fixed my issues. My Service Desk 4.5 is working perfectly.
saulsan
Acclaimed Contributor

Re: hp OpenView service desk error: "Microsoft ADO DB (Minimal required version: 2.1)"

You first have to run the msjavx86.exe, then you have to run MS-DOS (Command Promt).
enter the next description as it is:

regsvr32 "C:\Program Files\Common Files\System\ado\msado15.dll"

Don´t forget to install Radix Multi Instance and then install the Service Desk.

In case that this doesnt work (probably the SD will show a msg related to the server), uninstall Radix and then run the SD again, the last time I installed SD it was the solution to connect SD to the server.

This solution worked for me, hope it works for you.
//Add this to "OnDomLoad" event