Service Desk Practitioners Forum
cancel

error in SSP after upgrade to SP26

Highlighted
Michaela P.
Honored Contributor.

error in SSP after upgrade to SP26

Hi,
After upgrading the SD from SP20 to SP26 (and migrating Java from 1.4.2 to 1.5), I'm getting this error in SSP when trying to log in:

com.hp.itsm.api.interfaces.ITimeZones.getDSTUsable()Ljava/lang/Boolean;

Namely, this happens after upgrading the sp.jar in the web-inf/lib directory on tomcat - if I leave the old sp.jar, this error doesn't appear.

Does anybody have any idea?

Thanks
Michaela
5 REPLIES
The Pike
Acclaimed Contributor.

Re: error in SSP after upgrade to SP26

Michaela,

What's the output of running 'java -version' from the command prompt on the service pages server?

The Pike
Michaela P.
Honored Contributor.

Re: error in SSP after upgrade to SP26

Hi The Pike,

This is the output - Java 1.5 seems to be correctly installed (and also used by Tomcat - this java was specified during the tomcat service installation):

C:\Documents and Settings\Administrator>java -version
java version "1.5.0_19"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_19-b02)
Java HotSpot(TM) Client VM (build 1.5.0_19-b02, mixed mode, sharing)

Thanks for any idea,
Michaela
JaS_4
Acclaimed Contributor.

Re: error in SSP after upgrade to SP26

Have you tried clearing the service pages cache ?
C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\service pages\work
I find the leftover version residing in the work dir affect ssp after an upgrade.
Michaela P.
Honored Contributor.

Re: error in SSP after upgrade to SP26

JaS, the cache was certainly emptied. (Indeed, with the old SP, it actually works [even now after the upgrade], while we're getting this error with the new SP only...)

Michaela
JaS_4
Acclaimed Contributor.

Re: error in SSP after upgrade to SP26

Can you please list the date time and size of the sp.jar files from Sp20 and SP26 ?
I don't have a SP26 machine but maybe someone can check whether the date time and size of the sp.jar matches the sp versions.