Service Desk Practitioners Forum
cancel

application server not working

Highlighted
suhailqadri
Regular Contributor.

application server not working

the HPOV SP10 is not working from the server and from the client.
Error:Failed to connect to server.Check that the application server is running
12 REPLIES
George M. Meneg
Acclaimed Contributor.

Re: application server not working

Hello,

With application server stopped, delete its cache. Then restart.
menes fhtagn
suhailqadri
Regular Contributor.

Re: application server not working

Hi,
The error still persist,while starting the application server after removing the cache i could see some java exception,may be this could help so i attached the print.
The database is in another server:
sqlserver 8.0.760
Till yesterday it was working fine,today suddenly this problem started
suhailqadri
Regular Contributor.

Re: application server not working

Hi,
The problem still persist after removing the cache.while restarting the AS services i got some java exception which i'm attaching,may be this helps.the database is in another server:sqlserver 8.0.76
George M. Meneg
Acclaimed Contributor.

Re: application server not working

Hello,

Please do the following.

With server stopped, copy the log file to another location and clear it.

Delete the cache and start the server. Attach the log here.
menes fhtagn
suhailqadri
Regular Contributor.

Re: application server not working

Hi,
the service is shown as stop in windows services
well here are the log file.
Tue, 08/05/2007 12:33:33
Tue, 08/05/2007 12:33:33 ------------------------------------------------------------------------
Tue, 08/05/2007 12:33:33 hp OpenView service desk 4.5 (v4.5.0588.1004 (SP10))
Tue, 08/05/2007 12:33:33 Copyright (c) 2004 Hewlett-Packard Development Company, L.P. All Rights Reserved.
Tue, 08/05/2007 12:33:33 Server settings file: D:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\server_settings.xml
Tue, 08/05/2007 12:33:33 Install folder : D:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\
Tue, 08/05/2007 12:33:33 Data folder : D:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\
Tue, 08/05/2007 12:33:33 Java runtime name : Java(TM) 2 Runtime Environment, Standard Edition
Tue, 08/05/2007 12:33:33 Java runtime vendor : Sun Microsystems Inc.
Tue, 08/05/2007 12:33:33 Java runtime version: 1.4.2_05-b04
Tue, 08/05/2007 12:33:33 Java runtime home : C:\Program Files\Java\j2re1.4.2_05
Tue, 08/05/2007 12:33:33 Servername : ddbhelpdesk.dubaidb.local
Tue, 08/05/2007 12:33:33 IP Address : 10.248.1.57
Tue, 08/05/2007 12:33:33 OS name : Windows 2000
Tue, 08/05/2007 12:33:33 OS version : 5.0
Tue, 08/05/2007 12:33:33 OS architecture : x86
Tue, 08/05/2007 12:33:34 Started.
Tue, 08/05/2007 12:33:34 Started.
Tue, 08/05/2007 12:33:34 Started.
Tue, 08/05/2007 12:33:34 Starting agent manager on ddbhelpdesk.dubaidb.local
Tue, 08/05/2007 12:33:34 Job queue monitor starting.
Tue, 08/05/2007 12:33:34 Starting monitor for failed or expired jobs.
Tue, 08/05/2007 12:33:34 Started.
Tue, 08/05/2007 12:33:34 Starting multicast listener.
Tue, 08/05/2007 12:33:34 Started.
Tue, 08/05/2007 12:33:34 Initialized Opta SQL Server JDBC Driver DataSource
Tue, 08/05/2007 12:33:34 Initialized Opta SQL Server JDBC Driver DataSource
Tue, 08/05/2007 12:33:34 Restart DB Connection Checker
Tue, 08/05/2007 12:33:34 Starting Business Layer.
Tue, 08/05/2007 12:33:34 Getting system information from database.
Tue, 08/05/2007 12:33:34 : [DDBSQL]Changed database context to 'ServiceDesk'., SQL state: 01000
Tue, 08/05/2007 12:33:34 : [DDBSQL]Changed language setting to us_english., SQL state: 01000
Tue, 08/05/2007 12:33:34 Running in multiple server mode.
Tue, 08/05/2007 12:33:38 Systemjava.lang.NullPointerException
at com.hp.ifc.rep.AppItemFolderAccess.getStatusEntityID(Unknown Source)
at com.hp.ifc.rep.AppItemFolderAccess.getStatusFromOrdering(Unknown Source)
at com.hp.ifc.rep.AppItemFolderAccess.merge(Unknown Source)
at com.hp.ifc.rep.AppRoleInfo.merge(Unknown Source)
at com.hp.ifc.bus.AppSrvRepository.loadRoles(Unknown Source)
at com.hp.ifc.bus.AppBusinessManager.getRoleInfo(Unknown Source)
at com.hp.ifc.bus.AppBusinessManager.createSystemSession(Unknown Source)
at com.hp.ifc.bus.AppBusinessManager.bootstrap(Unknown Source)
at com.hp.ifc.bus.AppBusinessManager.(Unknown Source)
at com.hp.ifc.bus.AppServer.startup(Unknown Source)
at com.hp.ifc.bus.AppServer.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.hp.startup.Bootstrap.runprogram(Unknown Source)
at com.hp.startup.Bootstrap.main(Unknown Source)

Tue, 08/05/2007 12:33:38 End session.
George M. Meneg
Acclaimed Contributor.

Re: application server not working

Hello,

Can you execute the following queries?

DELETE from rep_sessions
DELETE from rep_servers

And start the server again? If it fails, please post the log.
menes fhtagn
suhailqadri
Regular Contributor.

Re: application server not working

Hi,
Is it delect * from rep_servers,

Anyhow in rep_sessions there are no rows
and in rep_servers there are 2 rows
suhailqadri
Regular Contributor.

Re: application server not working

Hi George,
Find the printout of the rep_servers rows from sqlserver.tell me if i delete this 2 rows.
regards
George M. Meneg
Acclaimed Contributor.

Re: application server not working

Hello,

Execute *BOTH* queries

DELETE from REP_SERVERS

DELETE from REP_SESSIONS

(Transact SQL syntax used by MS SQL)

It's nothing to worry deleteing, the entries will be recreated as soon as server starts and rep_sessions will be filled as soon as users start logging in.
menes fhtagn
suhailqadri
Regular Contributor.

Re: application server not working

Hi George,
The changes did not work and got the same log which i send u earlier.only one row was added to the rep_servers.but still no change in the output.
regards
suhail
JaS_4
Acclaimed Contributor.

Re: application server not working

Run sql query.
select count(*) from rep_roles_per_account where rpa_acc_oid=1;

Check if count is more than 1. If you have, you have have assign a role to system admin which lack access.


suhailqadri
Regular Contributor.

Re: application server not working

Hi,
the error was solved with
delete from rep_roles_per_account where rpa_acc_oid=1 and rpa_rol_oid!=2 and remove the cache to restart it.ecstatic to see it work . thanks a lot George and jas for your time to solve the error.
regards,
suhail