The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Weird command exec DB rule issue

Highlighted
Jan Gunnar Helg
Senior Member

Weird command exec DB rule issue

Hi

I have setup a DB command exec action rule to trigger a bat file with some params that again passes these to an exe file.

The problem is if I run the agent manually with "sd_agent.bat /MONITOR" i see the script being executed correctly and the information at my end gets updated.

But if I start the agent as a service and initate the DB rule again it does not work!

What gives?
3 REPLIES

Re: Weird command exec DB rule issue

Hello Jan,

this can be a credentials issue. Verify that the user under which the service is running has access to that file you are trying to launch.
Is there anything suspicious in the server log ?

Regards,
Ondra
Jan Gunnar Helg
Senior Member

Re: Weird command exec DB rule issue

I found the root cause. The application being called is written in .NET which doesnt like being started through a service

"EventType clr20r3, P1 bdd.exe, P2 1.0.0.0, P3 48ff1eb4, P4 system.directoryservices, P5 2.0.0.0, P6 4333aea9, P7 9a, P8 c4, P9 pszqoadhx1u5zahbhohghldgiy4qixhx, P10 NIL."

I've been googling some and it seems like a common issue. Im still working on how to fix it.
Jan Gunnar Helg
Senior Member

Re: Weird command exec DB rule issue

The solution is to run the Agent service with a domain users that have localadmin rights on the server itself.
//Add this to "OnDomLoad" event