Service Desk Practitioners Forum

Unwanted warning in 5.1

Go to solution
Ruth Porter
Acclaimed Contributor.

Unwanted warning in 5.1

Hi everyone,

In 5.1 if you log in with a role which only allows you to view a record but not modify, you get a warning "You are not allowed to Modify this record".

It did not seem to do this in 5.0 (or good old 4.5) but the release notice says nothing about any changes in this area.

Has anyone else noticed this and if possible found a work round because we find it very annoying!


Steven De Smet
Honored Contributor.

Re: Unwanted warning in 5.1


I believe I saw something similar during Beta. The actual problem was that opening a new assigned item by somebody with view only access, the automatic build-in logic tried to set the assignment status to accepted.

If the item assignment status is allready on accepted and you still get the message, you will have an other problem.

I hope this bring you 1 step closure to find the actual root cause.

Super Contributor.

Re: Unwanted warning in 5.1

Hi ruth

We are also suffering from this. We have logged a call with HP, and have been told that this is related to a bug, where when you only have read rights somehow the program behaves strange. If i remember right they believe this is fixed in SP1. I somehow have my doubts.

The original bug we report was that when you only have new and view rights to the history, which is what our users have. The Registration information of a history entry only displays correctly on the overview tab. When you open a history entry.(you get first the annoying error message you described) and then the registration information is either blank or it displays your own information. When you give the users modify rights it is displayed ok

Hope you get what I'm trying to explain ;-)

So HP told us both problems are related to each other. Hope it is true.
Ashly A K
Acclaimed Contributor.

Re: Unwanted warning in 5.1


Sorry, i am still with SD 5.0 POC.

Well, the role which has only read only permision, can those users access SD thru a browser? Will that reoslve ?
Or, create a custom filed, give read & write access for the role. Then, fill the field with a messge saying all the fileds are read only, user can;t make any chagnes.

May be this is a dirty thing, but i hope it will not give u the annoying message.

Respected Contributor.

Re: Unwanted warning in 5.1

Hi Ruth ,

There is a workaround, you grant your users the 'Modify' access right in that role, but under 'Advanced' for a desired object, you change the Access for ALL the attributes from Write into View, I did it like this and it works just fine.

Sean Almond
Honored Contributor.

Re: Unwanted warning in 5.1


Happy New Year long time no see!

We have this issue in 5.0 SP2 and it also present in 5.1.

We are currently running with a hotfix which solves only part of the issue.

I believe SP1 was already finalised before the full fix and that this may be finally fixed in SP2.

Not great I know but support should be able to resolve the major part of the bug wit a hotfix.

The workaround above only works if you have the roles structured in a specific way which we found that was unsuitable in most cases for our client.

Good Luck and all the best for the new year

Ruth Porter
Acclaimed Contributor.

Re: Unwanted warning in 5.1

Thanks Sean & happy New Year to you too