Service Desk Practitioners Forum

TimeZone Update

Vadim Gorda
Acclaimed Contributor.

TimeZone Update


System HP SD 4.5.

Faced the following issue. Due to the cancelation of the time change (summer/winter) for the Russian timezone, system time should have stayed intact. But in the system timezone was set change to offset +1 hour and as a result now system is running with incorrect time. From this year offset must be remaining to GMT+3 without changes.


Maybe there is some patch or general fix which does that changes? Or maybe someone has a ready solution for that?


Thank you for responses beforehand

Honored Contributor.

Re: TimeZone Update

From sp22+, you can edit the timezones yourselves, and even create a new timezone.
Tools > System > System Panel > Regional Settings > tab Time Zones.
But there is a little problem here, even with this flexible timezone function:
The Search code (MSKDT for Moscow) cannot be changed, and the offset (GMT+3) cannot be changed.
For the Moscow timezone, you want this:
    Name Moscow time
    Search code MSKDT  or MSK without DT, because the D means that there is a DST factor in effect.
    Offset 4
    [v] Add to display list
    [ ] DST Usable
You could try to edit the UTC+4 timezone from Abu Dhabi but it shows the wrong abbreviation then.
It is better to disable the predefined MSKDT record, and create a new timezone without DST, like this:
    Name Moscow time
    Search code MSK
    Offset 4
    [v] Add to display list
    [ ] DST Usable
Do the same for the other 8 timezones (offset 3 for Kaliningrad Oblast, 4 for Moscow, see

For (Russian) users on a lower servicepack than 22, there is only a workaround:

Users must choose the corresponding UTC+x offset entry from the toolbar, until they have upgraded to sp22 or higher.
HPE Software Support

If you find that this or any post resolves your issue, please mark it as an accepted solution. Kudos are welcome.