Service Desk Practitioners Forum
cancel

Strange Rule Behavior

SOLVED
Go to solution
Highlighted
Jeff Poling
Outstanding Contributor.

Strange Rule Behavior

I have two notification rules set up in SD 4.5 SP 15:

1. Email notification sent to workgroup when assignment is set to a workgroup
2. Email notification to a specifica person when assignment is set with a To person

Yesterday, an email was not sent as expected and I am trying to troubleshoot the issue. I was unable to duplicate the problem, but I did notice an oddity: When I assigned a service call to a workgroup, an email was sent to everyone in the group. Additionally, one of the people was sent the same email notification again. A snip from our log is attached.

Any idea how I can troubleshoot this further?

Thanks,

Jeff
3 REPLIES
Chris Bailey_3
Outstanding Contributor.

Re: Strange Rule Behavior

Jeff,

That behavior where it sends an e-mail to everyone in the workgroup if it isn't assigned to an individual is default behavior for Service Desk. You'd need to re-architect your db rules or else use some external notification program to avoid it.

As far as troubleshooting, does the server log report anything concerning the db rule firing or not firing?

Thanks,
Chris
Terry A. Moir
Outstanding Contributor.
Solution

Re: Strange Rule Behavior

We had a case some time ago where a person received two e-mails. It was caused by the fact he had his "send me e-mail when items are assigned to me" option turned on (we don't use this, have built DB rules instead). I set up a view from the Admin console to display persons with this turned on, and updated all to turn off.

Terry
Jeff Poling
Outstanding Contributor.

Re: Strange Rule Behavior

Thanks Terry. I completely forgot about the option int the client options for receiving emails. Once we removed that, the user only gets the email generated by my business rule.

Jeff