Service Desk Practitioners Forum
cancel

Stability problem, SD4.5 SP20 on W2K

SOLVED
Go to solution
Highlighted
Dusko Milosevic
Super Contributor.

Stability problem, SD4.5 SP20 on W2K

Dear all,

Recently, a problem occured. Service desk 4.5, SP20 sometimes just stop responding, and I cant make it work. Only Hardware reset of the server helps. Everything started two days ago, without any new instalation or something similiar. Users call and say that they can not log in. There is login screen without progres in the progress bar. During that situation, whoever works in SD can't save anything, and get the Not Responding message from Windows. Please advice because this sitaution repeats every few hours.

Thanks

Dusko.
13 REPLIES
Michel SILVA SO
Outstanding Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Hi Dusko,

what is your server log telling?

Rgds,
Michel
Dusko Milosevic
Super Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Wed, 15/11/2006 09:08:15 Queue overflow, flushing...
Wed, 15/11/2006 09:08:15 ServerGui Buffer full, cleared ServerGui logFile Monitor window
Wed, 15/11/2006 09:08:15 ServerGui Buffer full, cleared ServerGui logFile Monitor window

That is the last input in server log before I had to restart (hardware) server.

Dusko
Michel SILVA SO
Outstanding Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Darren McGiffen
Honored Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Hi Dusko,

Can you pls confirm:

Which Windows 2000 Service Pack you are running on the server OS?

Are you running the server application as an exe or as a service?

How many instances of the server application are you running on this server?

are there any other OVSD servers attached to the same database and if so do they have any problems?

Are there any relevant entries in the Windows system event log.

Does the server itself stop responding or just the OVSD application?
Dusko Milosevic
Super Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Darren,

Server runs on W2K SP4.
Application server runs as a service.
There is only one instance of server application.
There is only one OVSD server.
There are no relevant entries in Event viewer log.
Only OVSD application stop responding and cannot be stopped from the start menu. Dos prompt just hangs on "trying to stop local server..."

I thought that maybe the problem was caused by some Database Rules, so I block those suspicious rules. As the problem continues I delete those rules. We will see...

Thank you all for interesting in my problem.

Dusko
Ondra Ernyei
Honored Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Hello Dusko,

try to disable the SD server service, restart the box and run the SD server as an exe process to see if the issue is somehow related to a falty registered server service. It happened at our site once.

Let me know the result.

I hope it helps.

Ondra
Dusko Milosevic
Super Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

I did as you said, lets wait a bit to see if it will crash again.

Thx,

D.
Dusko Milosevic
Super Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

During last crash I catch a printscreen of a server. Please look at attachment.

Thx,

D.
Ondra Ernyei
Honored Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Dusko,

what is your Java version ? Please post the beginning of the logserver.txt just when you start the SD server service or process.

Ondra
Ondra Ernyei
Honored Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

For SD SP20, the best version is JRE/JDK 1.4.2_09.

Ondra
Ondra Ernyei
Honored Contributor.
Solution

Re: Stability problem, SD4.5 SP20 on W2K

Additionally, you may have a look to this issue which is open paralelly in the forum:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1074714

Ondra
Dusko Milosevic
Super Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

Thanks for helping. I installed the Java version you said, but that didn`t solve the issue. Then I edit those .bat files in post you gave me the link for. I hope that will solve my problem. We'll see.

Thx,

D.
Dusko Milosevic
Super Contributor.

Re: Stability problem, SD4.5 SP20 on W2K

As this was known issue, I think that I solve the problem with Ondra's help.

Thank you all for helping.

D.