Service Desk Practitioners Forum
cancel

Special chars in SD4.5 SP17

Highlighted
patrick gosseye1
Respected Contributor.

Special chars in SD4.5 SP17

HI,

When I import person in SD and the Name as special chars (example :Fréderic), nevertless I insert the parameter "ENCODING=ISO-8859-1" in my ini-file but the don't interprete them correctly.
Is there a workaround or a solution?

thanks in advanced,
Patrick
10 REPLIES
Venkatesha_1
Outstanding Contributor.

Re: Special chars in SD4.5 SP17

Hi,

The user you are using for import might default language as something else that you don't require.

Check out the details
Tools >> System >> Security >> Access >> application account >> Select the user.
see the "Default Language".

Set the required language & retry it.

Hope this solves
Venkatesha
patrick gosseye1
Respected Contributor.

Re: Special chars in SD4.5 SP17

Hi,

The default language is correct (Central european Time) for this account but doesn't encoding them correctly.

regards,
Patrick
patrick gosseye1
Respected Contributor.

Re: Special chars in SD4.5 SP17

Hi,

Is it possible that the encoding doesn't works on a W2K3 server?
Or am I wrong.

Best regards,
Patrick
patrick gosseye1
Respected Contributor.

Re: Special chars in SD4.5 SP17

Hi,

The default language is set to English, but it doesn't work.

Is there anybody who can help me.


Thanks,
Patrick
Carlos Thompson
Respected Contributor.

Re: Special chars in SD4.5 SP17

we don't have any encoding= parameters in our .ini files, but we are multinational with lots of wierd accents that never have any problems?

Try this in your .ini under the

COLUMNS=


STR([ODBCNAME].[NAME]) AS [NAME]

it might make the import just treat it as a string, definitely helps when you are dealing with numbers that you want SD to treat as strings.

similar formatting taking place in the .ini under the columns section:

Format([WORKSTATION].[LeaseExpiry],'dd-mmm-yyyy h:mm AM/PM') AS [LEASEEXPIRY], \
Format([WORKSTATION].[WarrantyExpiry],'dd-mmm-yyyy h:mm AM/PM') AS [WARRANTYEXPIRY], \
patrick gosseye1
Respected Contributor.

Re: Special chars in SD4.5 SP17

Hi,

I try it but when I export a error occured with the next message:
Section[USERS]:SqlError:[Microsoft][ODBC Text Driver] Too few parameter. Expected 1
ErrorNumber:5005

In the ODBC LASTNAME is specified as a char with a width of 255 and characters= OEM

In attache the .ini file

Regards,
Patrick
patrick gosseye1
Respected Contributor.

Re: Special chars in SD4.5 SP17

Hi Carlos,

As explaine before it doesn't run likely.
Perhaps I forgot something todo as mentioned in my reply before.
Because it is very urgent to find a solution is it possible to look on the attachement of my reply before.
Or is there anybody who have another idea.

Thanks,
Patrick
Carlos Thompson
Respected Contributor.

Re: Special chars in SD4.5 SP17

Too few parameter. Expected 1

That means your columns and names in your .ini are not matching....hmmmm
Jan Schepers
Super Contributor.

Re: Special chars in SD4.5 SP17

Did you already try
ENCODING=UTF-16
For me this works with most characters. Only one thing I noticed is that it gives issues when you use it in combination with delta hanling (the -recofile option).
patrick gosseye1
Respected Contributor.

Re: Special chars in SD4.5 SP17

Hi,

I try it as described but it doesn't works.
I changed my output file from a csv to a xml-file and I can import now directly in SD without to export them.
I wrote a .Net application who gives me the opportunity to export data from a open ldap server in a txt-file and then to create the xml-file as described in the SD exchange data doc.

Regards,
Patrick