The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Servicedesk performance problem

Highlighted
Regina Xfo
Super Collector

Servicedesk performance problem

Hello!
I have SD 4.5 sp19 on win2k3 servers.
using 2 application servers (4GB RAM each) and sql server on a seperate machine.
I have only 30 users and the SD is very slow.
Can anyone please suggest me how to improve perfomance? or can i find what cause this??

Thanks.
10 REPLIES
George M. Meneg
Honored Contributor

Re: Servicedesk performance problem

Hello,

Slowness has many aspects. What exactly is slow on your system ?
menes fhtagn
Ruth Porter
Honored Contributor

Re: Servicedesk performance problem

Hi there,

First check if there any useful messages in the log file (logserver.txt usually in C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\server\log).

If it has messages about memory problems, I think there is advcie in the Adminstrators Guide on allocating more memory to Java.

Hope this helps, Ruth
http://www.teamultra.net
Regina Xfo
Super Collector

Re: Servicedesk performance problem

Thank you for answering...
logging in to servicedesk and open a new service call for example are very slow..
I already tried to change the memory allocation but the clients couldn't connect to SD even after changing back to the defaults.finnaly i had to reinstall the application server.

Jay Mistry
Frequent Visitor

Re: Servicedesk performance problem

Hi

You might want to launch the Service Desk client from command line using the /BENCHMARK option:-

- launch cmd window
- run :\Program Files\Hewlett-Packard\OpenView\service desk 4.5\client\bin>sd_client /BENCHMARK

It will give you basic stats about the network, database etc.

Hope this helps

Jay
-=R=-
Frequent Visitor

Re: Servicedesk performance problem

Is the /benchmark option available in version 5.1 as well?
Regina Xfo
Super Collector

Re: Servicedesk performance problem

runing /BENCHMARK , everything seems to be very fast, but actually it works realy slow...
Vasily Kamenev
Honored Contributor

Re: Servicedesk performance problem

Hi
If you have 2 Application server and performance slow on each server, then problem on Network or SQL or your schedule is too murch. Chech the schedule, the tasks < 4000. Use task manger and check processes on SQL and Application server too, processos don't must spend more time on other processes. Run client directly on Application server, if you have diffence perf., then network.

Vasily
Regina Xfo
Super Collector

Re: Servicedesk performance problem

Hi Vasili,
I attached the benchmark so you can see that the network is ok, i have only 22 schedule tasks running now. processes on the App servers have peaks of 50% cpu once in a while, SQL processes are fine.

Any suggestions???

thanks.
Vasily Kamenev
Honored Contributor

Re: Servicedesk performance problem

Hi
When you doing DB installetion and update, all pass correctly? check the logdatabase.txt file about.

Vasily
JaS_4
Honored Contributor

Re: Servicedesk performance problem

Hi Regina,

I have an issue once where logon was slow but everything was fast after logon was completed. The issue turned out that the primary dns server was changed and the 2nd dns server does not work anymore. Once the correct primary dns was put in, logon was fast again.
Try checking your dns resolution of server hostname from the client and the client's hostname form the server.
Try a tracert of the server hostname from the client and see how long it takes.
You can also run the sd_servermanager and see how the response is.
//Add this to "OnDomLoad" event