Service Desk Practitioners Forum
cancel

Service Desk 4.5

Highlighted
GJJ2008
New Member.

Service Desk 4.5

Hi

I'm having problems opening my service desk 4.5 (client side) application. I'm using Sd4.5 and have installed the latest service pack (SP24). I get the following error when attempting to logon:

java.lang.NoSuchMethodError: com/hp/ifc/sys/AppSystem: method connect()V not found

Has anyone seen this before?

Thanks in advance
5 REPLIES
Err_1
Acclaimed Contributor.

Re: Service Desk 4.5

Hello,

have you tried clearing your client cache?

Remove the content of the following directory (except for the file views.dat):

C:\Documents and Settings\\Application Data\Hewlett-Packard\OpenView\Service Desk

Regards;
Randall Barrantes
SW Support Delivery Manager
GJJ2008
New Member.

Re: Service Desk 4.5

Thanks for this suggestion, i've just tried it and unfortunately it hasn't worked.

I deleted all contents of the suggested directory except for views.dat and restarted the application. These folders/files were recreated and I still got the same error

Thanks
Radovan Skolnik
Acclaimed Contributor.

Re: Service Desk 4.5

This seems pretty strange - missing such method on an object. Clearing cache can harldy help in this case - there's something wrong with your setup (maybe servicepack.jar missing from the lib directory?)

Uninstall the SD client, (re)install latest MS JVM (should be in unpacked SP24 directory in the tools), reinstall the client and SP.
benedicttorres
New Member.

Re: Service Desk 4.5

I am also having problems with this one. is there a known solution for this one already? i have already installed the latest SP and the latest JVM and it is still not working. Thanks.
Pradeep_30
Outstanding Contributor.

Re: Service Desk 4.5

Responding to very old post. Today while troubleshooting one client's error I ran into the same problem.

The fix for this was...

1) Backup Views.dat( if its not corrupt)
2) Delete the Service Desk folder from
%PROFILE%\Application Data\Hewlett-Packard\Openview

3) Start the service desk client

HTH