Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

SP not defaulting Caller Name - Urgent

Highlighted
Yvonne Duxfield
Regular Collector

SP not defaulting Caller Name - Urgent

Our Service pages are not showing the user when logged in and when you submit it is asking for Caller, there is no where to put it.

I have,
assigned each person record an Sp account, made sure the login is correct in SP deleted them all and tried agian with no success.

We are using a rule which defaults the login to one password so we have single sign on from windows.
3 REPLIES
Jonathon Druce
Honored Contributor

Re: SP not defaulting Caller Name - Urgent

Are you sure that you do not have duplicate accounts? How do you tell this. From the person record click on the qick find for account and look through the list. Is there any duplicates? Also make sure that the SP accounts are in the SP_USER role. They should be by default but sometimes this goes wrong.
Yvonne Duxfield
Regular Collector

Re: SP not defaulting Caller Name - Urgent

Hi Jonathan,
No duplicates and yes the the SP accounts are in the SP_USER role I have checked by going to the role and looking in the Accounts related to that role. I checked all the others and there are no duplicates there either.
Yvonne Duxfield
Regular Collector

Re: SP not defaulting Caller Name - Urgent

I think I have fixed it. I changed the script to pull the actual login instead of first name last name (some users do not have this as login) when creating the SP. It created a couple of duplicates but have cleared them and it seems to be working fine now.

thanks for your help
//Add this to "OnDomLoad" event