Service Desk Practitioners Forum
cancel

SMTP client on SD

Highlighted
PatrikT
Respected Contributor.

SMTP client on SD

Hi,
Im getting nervous. I've been reading all threads about the SMTP server in SD, checked and double checked at my site, but still ..

I am working on unix 11.1 and SD 4.5 SP20

I thought that the SD SMTP-listener was started when the server was started.

the sendmail SMTP is working, hence next example:
>telnet hpux2 2525
Trying...
Connected to hpux2.
Escape character is '^]'.
220 hpux2.mazdaeur.be ESMTP Sendmail 8.9.3 (PHNE_29774)/8.9.3; Tue, 17 Jun 2008 10:41:12 +0200 (METDST)


telnetting to the SD server:
>telnet sdprd 25
Trying...
telnet: Unable to connect to remote host: Connection refused

Sendmail on my SD production server:
>telnet hpux5 2525
Trying...
Connected to hpux5.
Escape character is '^]'.
220 hpux5.mle.mazdaeur.com ESMTP Sendmail 8.9.3 (PHNE_29774)/8.9.3; Tue, 17 Jun 2008 10:43:16 +0200 (METDST)

and the SD server:
>telnet hpux5 25
Trying...
Connected to hpux5.
Escape character is '^]'.
220 hpux5 service desk 4.5 SMTP Service Ready for input.

In attachment my server_settings.xml.

Has anybody an idea ?
4 REPLIES
PatrikT
Respected Contributor.

Re: SMTP client on SD

In addition, the outbound email is possible ... Many tests ok

Inbound goes via Exchange and is working on my other test server. All settings are in fact equal to that test server ...


Err_1
Acclaimed Contributor.

Re: SMTP client on SD

Hi,

the SD SMTP-listener starts when the SD services are started, unless something else is blocking SMTP port (25).

What is exactly your issue?
Randall Barrantes
SW Support Delivery Manager
PatrikT
Respected Contributor.

Re: SMTP client on SD

Hello All,

I have found the issue. Yes, the SMTP service is normally started as the application server is started, but I wanted to start this as non-root user. So "permission denied".

PatrikT
Respected Contributor.

Re: SMTP client on SD

As said above: solution = start the application server with enough permissions on SMTP service !