Service Desk Practitioners Forum
cancel

SD4.5 & SP23 (Vista errors)

SOLVED
Go to solution
Highlighted
aaron afilalo
Respected Contributor.

SD4.5 & SP23 (Vista errors)

Hi there,

I am considering applying SP23 to SD4.5.
SD4.5 client on Vista gives me “Incorrect version MS ADO DB (2.1)” when trying to open the client. Applying a newer version of ADO had no effect. HP support suggests loading SP23.

1. Has anyone encountered this error??
2. I am trying to find info. on any known errors or issues related to loading of SP23. We got some nasty surprises when we loaded SP21; known errors that were not communicated to us prior to the upgrade.
So does anyone know of issues or documents etc... listing issues related to the installation of SP23.

Thanks

Aaron
8 REPLIES
George M. Meneg
Acclaimed Contributor.

Re: SD4.5 & SP23 (Vista errors)

Hello Aaron,

Since SP23 is the first version to officially support Vista, upgrading to SP23 is one way road!
menes fhtagn
aaron afilalo
Respected Contributor.

Re: SD4.5 & SP23 (Vista errors)

Fortunately, I do not have to suffer through Upgrade or Die!! Only one of my 6 installed Vista clients has this error. All others work well. But of course, HP Support says upgrade to fix the issue. Not necessarily true.
George M. Meneg
Acclaimed Contributor.

Re: SD4.5 & SP23 (Vista errors)

Hello again,

SP23 is very fresh and anyone that has even little experience with OVSD service packs will not rush to upgrade. For example our upgrade policy is to test SP at least for a month before upgrading (since the only safe way to downgrade is through db restore). We have faced three nightmares (with SP10, SP14 and SP19) and we learned the hard way, to test again and again and again, then test again and after testing again, pray to $DEITY an deploy!
menes fhtagn
George M. Meneg
Acclaimed Contributor.

Re: SD4.5 & SP23 (Vista errors)

Hello again,

SP23 is very fresh and anyone that has even little experience with OVSD service packs will not rush to upgrade. For example our upgrade policy is to test SP at least for a month before upgrading (since the only safe way to downgrade is through db restore). We have faced three nightmares (with SP10, SP14 and SP19) and we learned the hard way, to test again and again and again, then test again and after testing again, pray to $DEITY and deploy!
menes fhtagn
aaron afilalo
Respected Contributor.

Re: SD4.5 & SP23 (Vista errors)

Since SP23 is so recent, I guess there are no real answers to either of my questions except as you say, test many times - upgrade once.

thanks for the advice.

Aaron
Vasily Kamenev
Acclaimed Contributor.
Solution

Re: SD4.5 & SP23 (Vista errors)

Hi
As I know the problem rise when install Office on Vista, try to do : regsvr32 "C:\Program Files\Common Files\System\ado\msado15.dll"
only by Admin account.

Vasily
aaron afilalo
Respected Contributor.

Re: SD4.5 & SP23 (Vista errors)

Vasily,
Like the machine repair man who explains his invoice of 75 dollars for making a machine work by simply hitting it once with a hammer - 1 dollar for hitting the machine and 74 dollars for knowing where to hit.
It works!! No need for risky SP loading.

Thank you very much.

aaron afilalo
Respected Contributor.

Re: SD4.5 & SP23 (Vista errors)

Closing thread due to solution provided by forum member.