Service Desk Practitioners Forum
cancel

SD views not visible for user under SP13

Highlighted
Tanel
Regular Contributor.

SD views not visible for user under SP13

Hello, and Happy New Year!

We got strange problem after upgrading our Servicedesk from SP9 to SP13. Some system views are not visible. Under Admin console views are there, roles who should see new view are described..
View is only visible for this person who has system administrator rights...

Does anyone has ideas howto solve this issue?

Regards,
Tanel
5 REPLIES
Michael Lutfi
Outstanding Contributor.

Re: SD views not visible for user under SP13

Please check if the view depends on another view and that view is also assigned to the role.

e.g. if you have a view called abc and its a chart view that uses the View xyz then the user needs to have both views in their role...
Tanel
Regular Contributor.

Re: SD views not visible for user under SP13

Noup. It's not depending on another view. Also checked roles.
Some tests with assigning same view to other roles. Only user who has system administrator right's can choose this view:(

but we have another "feature" in Servicedesk. As with SP13 has come new feature "Enhanced Auditing" but this is not visible for system administrator. Is it somehow related with views problem?

Mark O'Loughlin
Acclaimed Contributor.

Re: SD views not visible for user under SP13

Hi Tanel,

the attached doc on this thread will tell you what you need to know in setting up enhanced auditing

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=753764
Tanel
Regular Contributor.

Re: SD views not visible for user under SP13

My problem with views is solved. After disabling "Use Delayed Role Caching" under Admin console->System Panel and restarting servicedesk application and deleting all cache files from server, views appeared like needed:)

Tanel
Tanel
Regular Contributor.

Re: SD views not visible for user under SP13

problem solved