Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

SD Web Console

Highlighted
Guenther Schere
Frequent Visitor

SD Web Console

hi,

we try to install SD web console.

Web console (SP20) is installed on a separate machine than the application server (test - SP20).

Tomcat and Apache are running (on different ports).
Javaversion: 5.0
JAVAhome is defined.

When open http://localhost/ovportal we get the error:

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: Unable to compile class for JSP

An error occurred at line: -1 in the jsp file: null

Generated servlet error:

[javac] Compiling 1 source file



at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:130)
at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:293)
at
...
... many more errors
...
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:619)
at java.lang.Thread.run(Unknown Source)


What's going wrong?

Thank you
Guenther
6 REPLIES
Mike Bush
Honored Contributor

Re: SD Web Console

Was JAVA_HOME defined BEFORE you installed the web_console and it created its services? I remember issues with Service Pages many months back where I did the install, tried to set JAVA_HOME then and had similar problems (the JAVAC compiler is being called and not liking the environment it finds)
Guenther Schere
Frequent Visitor

Re: SD Web Console

Hi Mike,

first we installed the web console, set the java_home and when reinstalled the web console.
So I think it's ok.
The XP-Softwarelist shows: J2SE Runtime Environment 5.0 Update 6.0 (Sun - internal Version 1.5.0.60)

Thank you
Guenther
Guenther Schere
Frequent Visitor

Re: SD Web Console

ohoh.
Now I've seen JRE 1.5 is not supported.
Ok. We will try it with 1.4.
Sorry.

Guenther
Guenther Schere
Frequent Visitor

Re: SD Web Console

hm.
The same error with JRE 1.4.2.
JAVA_HOME is set before the new installation.

Thanks
Guenther
Ashly A K
Honored Contributor

Re: SD Web Console

hi!

Few weeks back i was fighting with Web Console,and it is up now!!

Well, below are the actions i did.

01.removed all the java installations
02. cleared the registry
03. installed the recommended version of java
04. set the java_home
05. Added the Java in the Path
06. installed the Web Console
07. started the Apache in console mode
08. it just worked!
09. some of the GIF images was not displayed.
10. looked at the code of the HTML pages and made few copy & past of GIF

Hope this helps.

Ashly A K
http://www.geocities.com/helponhpopenview
Guenther Schere
Frequent Visitor

Re: SD Web Console

Reading helps. RTFM.
JDK and correct Java_home and it works fine.

Thank you all.
//Add this to "OnDomLoad" event