Service Desk Practitioners Forum
cancel

SD HPUX Upgrade from sp4 to sp17

Highlighted
Lennart Wiklund
Contributor.

SD HPUX Upgrade from sp4 to sp17

Regarding Java1.3 on HPUX 11i
We hade large problems starting the server and the sd_dbconfwizard after upgrading from sp4 to sp17
Java error from logdatabase
Java runtime version: 1.3.1 1.3.1.13-_10_feb_2004_17_15 PA2.0
Java runtime home : /opt/java1.3_13/jre
Servername : tppovw01.bss.telenor.com.pk
IP Address : 10.1.4.20
OS name : HP-UX
OS version : B.11.11
OS architecture : PA_RISC2.0
database configuration wizard started.
Initialized Oracle Thin JDBC Driver DataSource
Error in openConnection !
Failed to open connection to service desk data.


Trace from logserver.txt
Initialized Oracle Thin JDBC Driver DataSource
Failed to open connection to service desk data.

End session.
Starting scheduled rule actions queue.
Unable to start serverjava.lang.ExceptionInInitializerError: The repository is not loaded
at com.hp.ifc.bus.AppSrvDispatch.invoke(Unknown Source)
at com.hp.ifc.rep.AppRepository.refresh(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.initialize(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.initialize(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.(Unknown Source)
at com.hp.ifc.bus.AppServer.startup(Unknown Source)
at com.hp.ifc.bus.AppServer.main(Unknown Source)
at java.lang.reflect.Method.invoke(Native Method)
at com.hp.startup.Bootstrap.runprogram(Unknown Source)
at com.hp.startup.Bootstrap.main(Unknown Source)

When changing to Java1.4 the problem dissapered

Is not so that SD requires and states that Java1.3 is the version to use?