Service Desk Practitioners Forum
cancel

SD_EVENT faild to get defult values from template

Highlighted
Catherine Doce
Super Contributor.

SD_EVENT faild to get defult values from template

Dear All,
I working on SD 4.5 SP17
I use sd_event to creat a change with defult values in certain template in import mapping
it was working probrly but suddenly the sd_event can't feel the values in the assigned template and the error is "For change the following fields are required: status." and this value already in the template.
if any one could help will be appritiated
6 REPLIES
Van der Vennet
Honored Contributor.

Re: SD_EVENT faild to get defult values from template

hi catherine,

can i see the error log file that has been created, the mapping that is performed and the bat file that creates the change?

are you sure that the used status is not blocked?
we have been where you wanna go..
Catherine Doce
Super Contributor.

Re: SD_EVENT faild to get defult values from template

The error log file is attached in the threade
and what dose you mean bu bloking the status?
note: it dosen't fell by any value in the template, but it gives the error for the status because it is mandatory field, if i pass it manually from the comand line it will create an empty change without any passing values in the template.


the comand line: " specified pass>sd_event.exe -f importfile.ini -v desc="change description"
this attachment her is the ini file
Van der Vennet
Honored Contributor.

Re: SD_EVENT faild to get defult values from template

Hi catherine,

as I can read you do not give all the values requested

the file should contain all the required fields that have been mentioned:

-v DESCRIPTION="test" STATUS="Registered" INFORMATION="test" SOURCEID="ID123" ......

Mention all the information required, perform a correct mapping, otherwise give your e-mail and I'll send you an example for this
we have been where you wanna go..
Catherine Doce
Super Contributor.

Re: SD_EVENT faild to get defult values from template

This is the way to pass the parameters manually or to give it a defult vales in imortmapping template.

i can't pass it manually because the template contain relation with service call.
Ruth Porter
Acclaimed Contributor.

Re: SD_EVENT faild to get defult values from template

Hi Catherine,

The first thing to try is using the template through the client and check that it works there.

If it does not, you need to check the template; if it does, then it is the data exchange area you need to look at.

When you have done this test, can you post screen shots of the relevant screens and perhaps someone can help.

Regards

Ruth
http://www.teamultra.net
Michael Krongar
Trusted Contributor.

Re: SD_EVENT faild to get defult values from template

I had a similar problem. I found that the failure to pickup the default values from the template was related to another problem - where changes to the templates were not picked up by the application server until you cycled the application service (stopped and restarted the Service Desk server service).

You might want to check that.