Service Desk Practitioners Forum
cancel

SD 5.1 Service Pages SSL (we have it working in dev!)

Highlighted
Chris Terzian
Trusted Contributor.

SD 5.1 Service Pages SSL (we have it working in dev!)

ok guys. Here's a chance to make some big points. With the help of our Fox IT friends, we were able to get SSL working in Service Pages by replacing the existing Apache instance with a mod SSL version available off of the web. This was great news for us as we could then have people securely connect to Service Pages and utilize the ldap authentication we created for it as well.

So what's the problem? This worked great on our Windows 2003 Standard edition servers (2 of them). However, as soon as we moved the configuration over to Windows 2003 Enterprise, it no longer works. It appears to be one or more of the modules in the \apache\a\modules folder and/or one or more of the files in \apache\a\bin. When we start the web services, apache just freezes at 'starting'. The log doesn't really give us anything good info:

[Mon Apr 16 13:12:16 2007] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Apr 16 13:12:16 2007] [notice] Child 824: Exit event signaled. Child process is ending.
[Mon Apr 16 13:12:17 2007] [warn] (OS 10038)An operation was attempted on something that is not a socket. : setsockopt(SO_UPDATE_ACCEPT_CONTEXT) failed.
[Mon Apr 16 13:12:17 2007] [notice] Child 824: Released the start mutex
[Mon Apr 16 13:12:18 2007] [notice] Child 824: Waiting for 250 worker threads to exit.
[Mon Apr 16 13:12:46 2007] [notice] Parent: Forcing termination of child process 252

A search of the warning comes up with a known error at apache.org, which I'd be following up with more if it weren't working on our other servers. I did try replacing Apache 2.0.48 with 2.0.49 which got rid of that warning, but it still doesn't start. Any ideas of what to try?