Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

SD 4.5 SP28-30 on Java 1.6

Highlighted
Orestik
Super Collector

SD 4.5 SP28-30 on Java 1.6

All Good Day! There are sore and do not solve problems with the launch of the service SD 4.5 SP28-30 on Java 1.6, pops up an error of this kind:
Could not load the Java Virtual Machine,
The LoadLibrary function failed for the following reason: The specified module could not be found.
Log Ca empty! Help solve this problem !!!!!!
8 REPLIES
The Pike
Honored Contributor

Re: SD 4.5 SP28-30 on Java 1.6

If you just upgraded *from* SP28 *to* SP30 and upgraded the Java version as well, you might want to run reinstallservice.bat so the Windows service is updated with the new path to the Java libraries.

Hope this helps!

Do not forget to assign points to this post for the guidance...

The Pike
Err_1
Honored Contributor

Re: SD 4.5 SP28-30 on Java 1.6

As The Pike said,

Always check your java!!!

after you change/upgrade your Java make sure to reinstall the service, and that the JAVA_HOME is pointing to the new installed/upgraded java installation directories.

Run "java -version" from your command line, it might give you an idea what you currently have.

Regards;
Randall Barrantes
SW Support Delivery Manager
Orestik
Super Collector

Re: SD 4.5 SP28-30 on Java 1.6

The situation is this, talking with many colleagues in the Service Desk 4.5. I know that they have standing under java 1.6 SP28 and problems with the launch of the service is not currently at the moment I have java 1.5 and is SP28, underneath it all works super and starts to cheer, but to start the service to Java 1.6 can not be obtained by hand yes, the service starts, but no more! All this was done on a clean OS install awake and check on the command line version, then copying a variable, then put himself aplik server, update the joint venture, and set to overload a service, then check the connection to the database and start, but not successfully. As far as I know officially support java 1,6 only with the SP30. Having tried many options, forward specific help, since it is already sore problem!
The Pike
Honored Contributor

Re: SD 4.5 SP28-30 on Java 1.6

I have problems understanding some parts of your post.

Just to be clear, SP30 supports both Java 1.5 and 1.6. Support for Java 1.6 ONLY, starts with SP31.

I just forced the same error message by renaming the Java folder.

Assigning points might encourage further participation from members in the SD community. Remember the points mechanism is the way to reward other participants for their efforts in helping solve your problem.

Points for guidance are welcome!

The Pike
Orestik
Super Collector

Re: SD 4.5 SP28-30 on Java 1.6

may translate to my problem is not exact, since I write through the translator Google, I myself am from Russia and did not know English .... The problem is that there is a DB Oracle 9, server itself the Service desk on Windows Server 2003, installed SP28 and all wanted to work on Java 1.6, there have been many attempts to start the service desk the Service, but did not lead to success. It remains only to go to SP30 or higher and try a Java-1.6?!
Err_1
Honored Contributor

Re: SD 4.5 SP28-30 on Java 1.6

Exactly.... to be able to use Java 1.6 you will need to upgrade to SM31 or higher.

Regards;
Randall Barrantes
SW Support Delivery Manager
The Pike
Honored Contributor

Re: SD 4.5 SP28-30 on Java 1.6

So, if I understand correctly, what you want to do is run SP28 with Java 1.6? If it is, then you need SP30 indeed.

You might want to keep the supported platforms list handy:
http://support.openview.hp.com/selfsolve/document/KM112648

Hope this helps.
Points are welcome.

The Pike
Orestik
Super Collector

Re: SD 4.5 SP28-30 on Java 1.6

yes, but many of my colleagues without any problem under java 1.6 SP28 run. Well, I'll try to update! Anyway thanks for your support! until there was going to write to you, install SP36, a little podshamanil all started! Thank you all!
//Add this to "OnDomLoad" event