Service Desk Practitioners Forum
cancel

SD 4.5 SP17 inbound e-mail error

Highlighted
hladr
Valued Contributor.

SD 4.5 SP17 inbound e-mail error

Hello
when I'm traying to send e-mail to servicedesk, I get "No such user here" response.
When I tried SMTP communication:

220 servicedesk.domain.cz service desk 4.5 SMTP Service Ready for input.
ehlo me
250 Hello me nice to meet you.
mail from:
250 OK
rcpt to:
250 OK
data
354 Start mail input; end with .
hello

It wrote this to logserver.txt:

Út, 21/11/2006 14:44:20 Header : [hello
, .
]
Út, 21/11/2006 14:44:20 Subject :
Út, 21/11/2006 14:44:20 To : []
Út, 21/11/2006 14:44:20 Plaintext :

Út, 21/11/2006 14:44:20 Attachments: []
Út, 21/11/2006 14:44:20 Reply-To : null
Út, 21/11/2006 14:44:20 Reply-To :
Út, 21/11/2006 14:44:20 Mail from : null
Út, 21/11/2006 14:44:20 ReturnPath : hladr@domain.cz
Út, 21/11/2006 14:44:20 Importance : normal
Út, 21/11/2006 14:44:20 SMTPERRORjava.lang.NullPointerException
at com.hp.itsm.srv.email.EmailParser.parse(Unknown Source)
at java.lang.reflect.Method.invoke(Native Method)
at com.hp.ifc.net.smtp.AppSmtpRequestHandler.process(Unknown Source)
at com.hp.ifc.net.tcp.AppTcpConnection.processRequest(Unknown Source)
at com.hp.ifc.net.tcp.AppTcpThread.run(Unknown Source)



Can anybody help me?
Thank you
8 REPLIES
Alex Ivanov
Frequent Contributor.

Re: SD 4.5 SP17 inbound e-mail error

In your persons (personal) base exist user with e-mail from which the letter is sent?

If user does not exist you must create this person and fill email, from which the letter is sent.
hladr
Valued Contributor.

Re: SD 4.5 SP17 inbound e-mail error

Thanks for your idea, Alex, but the problem is somewhere else. There is a person with this e-mail address.
Robert S. Falko
Acclaimed Contributor.

Re: SD 4.5 SP17 inbound e-mail error

On the properties for the email command, you need to set whether OVSD will accept email:

- without any controls
- only from persons defined in OVSD with email field correctly completed
- only from persons with email AND with an OVSD account
- unavailable

Check that you have made the selection that you require.

-Josh
hladr
Valued Contributor.

Re: SD 4.5 SP17 inbound e-mail error

I have set "without any controls"...
Jonathon Druce
Acclaimed Contributor.

Re: SD 4.5 SP17 inbound e-mail error

Do you have "Use new command as default" selected for incomming emails as I notice you have no subject?

I normally see more infomative errors and it maybe that your server cache is not very happy. Try stopping the server and clearing the cache.
hladr
Valued Contributor.

Re: SD 4.5 SP17 inbound e-mail error

Thanks to everybody, I don't know why, but it's working now. Probably some problem with cache. I cleared cache, restart services and it is OK now...
Dean Morrell
Honored Contributor.

Re: SD 4.5 SP17 inbound e-mail error

I've found that restarting the service occasionally helps some really strange problems that just don't make sense...
I know the voices in my head aren't real, but they still have some REALLY FUN ideas.
Rachid Jarouy_1
Trusted Contributor.

Re: SD 4.5 SP17 inbound e-mail error

Dear hladr,
i am intersted in clearing the cache as you did,
can you please send the foul commad or the procedure if any,
your help is much aprecieted,
thanks in advence.
rachid.
beleve that workgroup give more and efficient result