Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Restoring Customised Views after OV Profile re-creation(OVSD 4.5 SP20)

Highlighted
PeterGray
Occasional Contributor

Restoring Customised Views after OV Profile re-creation(OVSD 4.5 SP20)

Hi,

I have recreated a users profile after after the following error message was received:
Java.Lang.RuntimeException:InvalidResourceHeader

After getting the suer logged back in their customised views are not available.

The old profile was retained & adding the old views.dat file or/and other .dat files & ATB files to the new profile (with the exception of the faulty .dat file) does not restore the customised views.

Would anyone have a fix for restoring the customised view.

Thanks,

Peter
3 REPLIES
Ruth Porter
Honored Contributor

Re: Restoring Customised Views after OV Profile re-creation(OVSD 4.5 SP20)

Hi Peter,

I am not sure I fully understand, but locally customised views are save in the views.dat.

Unless that is corrupt it should work.

If it does not, the user will have to recreate his views.

My recommendation would be that NO views which are essential to a user should be local - tehy should request them as system views as you cannot guarantee they will stay available.

Hope this hlps, Ruth
http://www.teamultra.net
Mark O'Loughlin
Honored Contributor

Re: Restoring Customised Views after OV Profile re-creation(OVSD 4.5 SP20)

Hi Peter,

have you tried to copy them onto another client system and see if they work?

Did you by any change make any changes to their application account at the same time?

What size is the views.dat. When you copied it back to the client did you still get the error or did you just get no personal views?

PeterGray
Occasional Contributor

Re: Restoring Customised Views after OV Profile re-creation(OVSD 4.5 SP20)

Hi Mark,

have you tried to copy them onto another client system and see if they work?- No, might give that a go

Did you by any change make any changes to their application account at the same time? No changes made.

What size is the views.dat. When you copied it back to the client did you still get the error or did you just get no personal views? Views.dat file was 121kb. When I copied it back was able to log in but there were no customised views.

I have located a possible fix which is as follows:
"I also had the same error even after deleting the cache folder so I made a copy of the Service Desk folder under:
Documents and Settings\â  userâ  \Application Data\Hewlett-Packard\OpenView\Service Desk (and Copy of Service Desk)

And under the original Service Desk Folder I deleted all the DAT files except the Views.DAT and the ATB files (2 ATB files) and also left all of the subfolders alone. Then I double click the Service Desk Icon on the desktop and went through the client startup again; server name, user name, and friendly name, everything came back and the Views were set to that users profile"

A bit strange but when tested on a working app. a/c does work so I will try this.

Thanks for your help.

Peter

//Add this to "OnDomLoad" event