Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems setting UI rule to set folder

Highlighted
Rory Emmans
Member

Problems setting UI rule to set folder

I am doing some folder testing and want to create a UI rule to set the folder based on the application account that is creating the ticket. I have created a role called Support Request" an Application Account called "Support Request" and a person record called "Support Request" Whith the Person record related to the Application account. The person record has a folder defined we will call "General" I have no folder defined in the template so it is blank when opening a Support Request. I have tried a bunch of different UI rules to set the folder to Entered by person folder but it does not work. I receive a error which I have attached below it basically says it is null.
5 REPLIES
Mark O'Loughlin
Honored Contributor

Re: Problems setting UI rule to set folder

Hi Rory,

could this be because a person can be related to multiple folders through the account or through role assignments. Sorry to answer with a question though it is what comes to mind. I can't verify this at the moment though so not sure at the moment.

Whats the rule that you are using and does the account have permissions to more that one folder by account or role assigments?
Marc Hummel
Frequent Visitor

Re: Problems setting UI rule to set folder

ex. ui rule.

new item created, folder - empty, update data, set folder to assignment to workgroup folder.

existing item opened, folder empty, update data, set folder to assigned workgroup.

starting point.
hth
Wounds heel, Pain fades... chix dig scar's, oh and everybody WangChung.
Rory Emmans
Member

Re: Problems setting UI rule to set folder

The roles are only related to the one account and the one workgroup. I have three acounts, persons and roles and folders each independant of each other that I am using for test. None of them work not even when I use the system account. I have also tried the UI Rules that were mentioed in this thread with no luck. I know the folder permissions part is work because I can only select the folder that is related to the ID account that I logged in with. The folder is grayed out but I can still select the folder. So I am confused why this does not work. I have tried UI and DB rules when Support Request opened closed etc with no luck. I am running SD4.5 with SP18
David Borojevic
Frequent Visitor

Re: Problems setting UI rule to set folder

Maybe I am missing the point - so feel free to ignore this.

Could you simply have seperate default templates per role and the templates set the folder. No UI rule needed? ie you would need at least one role per folder and one default template per role.

Cheers

Rory Emmans
Member

Re: Problems setting UI rule to set folder

I really did not want to use templates for that if at all possible. I would think it should be easy to set the folder by a UI rule but for some reason it will not work
//Add this to "OnDomLoad" event