Service Desk Practitioners Forum

Problem with ServicePages after installation

Mathias Byrö
Respected Contributor.

Problem with ServicePages after installation

Hi (again)!

As I wrote in my previous post, we had Web Console installed on our Service Desk Application Server, which wasn't that good. We have now uninstalled Web Console on our Service Desk Application Server (and the Java SDK required for the Web Console).

After that we installed Service Pages (on the Service Desk Application Server), reinstalled Java SDK (1.4.2_10), added a new environment variable, JAVA_HOME=C:\Program Files\Java\j2sdk1.4.2_10, changed the C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\service pages\webapps\sd-sp45\WEB-INF\web.xml first context parameter from localhost to the servers IP-address.

After that we did run the installtomcatservice.bat.

So far so good, we tried to access the start page by enter http://localhost/sd-sp45/index.html in our web browser, but the page were not found, so we tried it on port 8080, which led us to the correct page. (We later changed it to port 80 by alter the file C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\service pages\conf\system.xml).

Ok, we then tried to log in by enter our usual credentials, but received the following error message: Failed reading response from the server. We then created a new Service Page user by using the Administrator Console in Service Desk, but once again we ran into that same error message. We then entered a nonsense username and password, but then we got another error message in Swedish(!), saying something like this: Access denied: wrong username or password. Press OK to try again.

In my world this should indicate that we have a proper connection to our Service Desk Database, but what can be wrong?

Just to clarify: we have both Java 2 Runtime Environment, SE v.1.4.2_10 and Java 2 SDK, SE v.1.4.2_10 installed on our server, could this have something to do with our problems?

Best regards
Mark O'Loughlin
Acclaimed Contributor.

Re: Problem with ServicePages after installation


Ensure the tomcat service is running - it should be listed in the services as hp Service Pages

Look for the file "web.xml". In the first bunch of parameters there is a setting to point the SP install to an app server. By default it is set to localhost. Chnage this to the machine name of the server or the fqdn and then stop and restart the service.

If that fails uninstall the service for service pages (not the SP install) and reinstll is again and try again.
Jonathon Druce
Acclaimed Contributor.

Re: Problem with ServicePages after installation

You also get that error message when there is a service pack mismatch between the application server and the service pages installation.
Acclaimed Contributor.

Re: Problem with ServicePages after installation

You are suppose to be able to check the servicepages version by running this command. From a MS-DOS prompt, change directory to:
C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\service pages\webapps\sd-sp45\WEB-INF\lib
Run the following command against the web-api.jar:
java -cp .\web-api.jar com.hp.ifc.sys.AppVersionInfo

However, I still prefer to compare C:\sd45\service pages\webapps\sd-sp45\WEB-INF\lib\sp.jar with sp.jar file that I know belongs to a particular servicepack version.

Mathias Byrö
Respected Contributor.

Re: Problem with ServicePages after installation

Hi and thank you all for your replies!

The final solution was to completely uninstall ServicePages and after that install it again. One possible thing that could have caused this is that I wasn't prompted to reboot my server after I upgraded ServicePages to sp21 (which I were during the second attempt).

Thank you all once again!

Regards, Mathias