Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Required fields on different Forms.

SOLVED
Go to solution
Highlighted
Fenny_1
Collector

Problem with Required fields on different Forms.

Hi All,
I have made two different forms for two different depts according to their requirement.
1. Incident form for Technical
2. Incident form for IT
Now the problem am facing is that, i have made few fields mandatory on Incident form for technical at the time they close the Incident.
Say the fields name's are
1. Problem Solved by
2. Site Access time

Now these fields are not required on Incident form for IT and infact i didnt place these fields on this form. But still when the user is closing the incident here, the system is asking for Problem solved by and site access time.
Both are the form's have different templates assigned.
Can anyone help me in this regard. As i need to resolve this asap.

Thanks to all in advance.
13 REPLIES
George M. Meneg
Honored Contributor
Solution

Re: Problem with Required fields on different Forms.

Hello,

I'm guessing that you are using OVSD 4.5 since OVSD v5 required fields can be set on condition and not on status.

Since IT uses different template, fill this values on the template. So when IT closes the incident OVSD won't complain.
menes fhtagn
Fenny_1
Collector

Re: Problem with Required fields on different Forms.

Hi George,
Yes, am using SD 4.5 with SP17.
I tried the Template option but it wont work. Please tell me whether i need to stop and start SD application service to make the changes take effect in templates.

waiting for a quick response
George M. Meneg
Honored Contributor

Re: Problem with Required fields on different Forms.

Hello Fenny,

Yes, I think SP17 has a bug with templates and need service restart for changes to take effect.

However the best way to try is to open the Technical form and select IT incident template to see weather the values are filled.
menes fhtagn
Fenny_1
Collector

Re: Problem with Required fields on different Forms.

Hi George,
I have tried the template with Technical form and it worked.
So that means i need to stop and start the service to make this template effect on IT form??

Thanks for all your suggestions till now
George M. Meneg
Honored Contributor

Re: Problem with Required fields on different Forms.

Hello,

If it works then you don't need to restart the service. Probably a client restart is enough.
menes fhtagn
George M. Meneg
Honored Contributor

Re: Problem with Required fields on different Forms.

And something else: From your profile I see that you have assigned points only to 3 out of 192 responses you have received for your questions.

Assigning points is a good idea and strongly encouraged. Have a look at http://forums1.itrc.hp.com/service/forums/helptips.do?#28
menes fhtagn
Fenny_1
Collector

Re: Problem with Required fields on different Forms.

Hi George,
I already did a client restart but it doesnt work.
To be sure, by client restart i mean i closed my service desk client on my desktop and relogin into it.

As far as the points are concerned, i always assigned points in thread. Please tell me one thing do i need to assign to all the replies i receive. Because i assigned the points to your previous two replies but i didnt noticed them on these replies
George M. Meneg
Honored Contributor

Re: Problem with Required fields on different Forms.

Hello Fenny,

If client restart didn't work then you should consider to restart the application server.

About points, assigning points is not enough, you should also press submit.
menes fhtagn
Fenny_1
Collector

Re: Problem with Required fields on different Forms.

Hi George,
After restart it worked. Thanks alot to you.
One more thing, can you tell me how can i set a default template for a form.

Thanks alot once again
Ruth Porter
Honored Contributor

Re: Problem with Required fields on different Forms.

Hi there,

To set a default template - you can set this on the template defintion (check the deafult template box) and also you set it on a role: select the object type on the role, click advanced, go to Template tab, select the relevant template and then press the "default" button.

You use the same approach to set the defualt form for a role.

Hope this helps

Ruth
http://www.teamultra.net
Fenny_1
Collector

Re: Problem with Required fields on different Forms.

Hi ruth,
I want to set default templates for different forms. Can i do that?

As per your suggestion, i can only set one default template for incidents.

There are few roles in which access more than one forms so it cant be implemented in my case
George M. Meneg
Honored Contributor

Re: Problem with Required fields on different Forms.

Hello Fenny,

This can't be done in your OVSD version. It requires Dynamic Forms functionality, introduced on SP18.

The idea is to create a generic relation between Templates and Forms and treat your forms as subform.
menes fhtagn
Fenny_1
Collector

Re: Problem with Required fields on different Forms.

Thanks Goerge and Ruth, for your valuable guidelines.
Problem is resolved. Thanks alot
//Add this to "OnDomLoad" event