Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with OVSD 4.5 SP21 upgrade to SP25

Highlighted
Artis Stals
Occasional Advisor

Problem with OVSD 4.5 SP21 upgrade to SP25

Service desk: 4.5 SP21
Java version: 1.3.1_03
JSDK: 1.4.2_13
MS SQL 2000 with SP4 (CS_Latvian)

Don't upgrade database.

Log:
Pk, 22/02/2008 13:57:47 Starting Business Layer.
Pk, 22/02/2008 13:57:47 Getting system information from database.
Pk, 22/02/2008 13:57:47 : [AMIEN]Changed database context to 'servicedeskDB'., SQL state: 01000
Pk, 22/02/2008 13:57:47 : [AMIEN]Changed language setting to us_english., SQL state: 01000
Pk, 22/02/2008 13:57:47 The version of the application server on server.contoso.com (v4.5.0588.2505) is not compatible with the hp OpenView service desk database version (v4.5.0588.0904).
Pk, 22/02/2008 13:57:47 Systemjava.lang.Error: The version of the application server on server.contoso.com (v4.5.0588.2505) is not compatible with the hp OpenView service desk database version (v4.5.0588.0904).
at com.hp.ifc.bus.AppBusinessManager.bootstrap(Unknown Source)
at com.hp.ifc.bus.AppBusinessManager.(Unknown Source)
at com.hp.ifc.bus.AppServer.startup(Unknown Source)
at com.hp.ifc.install.database.AppUpgradeDatabase.run(AppUpgradeDatabase.java)
at java.lang.Thread.run(Unknown Source)

Pk, 22/02/2008 13:57:47 End session.
Pk, 22/02/2008 13:57:47 java.lang.ExceptionInInitializerError
at com.hp.ifc.bus.AppServer.startup(Unknown Source)
at com.hp.ifc.install.database.AppUpgradeDatabase.run(AppUpgradeDatabase.java)
at java.lang.Thread.run(Unknown Source)
Caused by: The repository is not loaded
at com.hp.ifc.bus.AppSrvDispatch.invoke(Unknown Source)
at com.hp.ifc.rep.AppRepository.refresh(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.initialize(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.initialize(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.(Unknown Source)
at com.hp.ifc.rep.AppGeneralSettings.(Unknown Source)
... 3 more

Pk, 22/02/2008 13:57:47 Total errors in data statements:0
Pk, 22/02/2008 13:57:47 Total errors in repo statements:0
Pk, 22/02/2008 13:57:47 The upgrade has failed! Look at the log file to find the reason of the failure.
Pk, 22/02/2008 13:57:47 Starting scheduled rule actions queue.
Pk, 22/02/2008 13:58:07 hp OpenView service desk 4.5 Database Configuration Log file ended.
6 REPLIES

Re: Problem with OVSD 4.5 SP21 upgrade to SP25

Is see this error in the log:
The version of the application server on server.contoso.com (v4.5.0588.2505) is not compatible with the hp OpenView service desk database version (v4.5.0588.0904).

Did you upgrade with the following steps:
1. Update the client, agent and server
2. stop the SD services on the SD application server
3. Run the database configuration wizard (from the start --> programs menu --> hp menu) and upgrade the DB to SP25.
4. Start the SD services again
5. Start SD

This should do it. Where did it go wrong?
Artis Stals
Occasional Advisor

Re: Problem with OVSD 4.5 SP21 upgrade to SP25

This problem while step3 - database configuration wizard.

Re: Problem with OVSD 4.5 SP21 upgrade to SP25

I had sort of the same problem last week.

To solve this problem i took the following steps:
1. re-upgrade the client, agent and server.
2. Reboot the server!
3. Stop all HP (SD) services on the SD application server
4. Run the database configuration wizard (from the start --> programs menu --> hp menu) and upgrade the DB to SP25.
5. Start the SD services again
6. Start SD

Try it again with a reboot and after that the upgrade. Or try to stop the services even before the upgrade of the agent,client and server!
Artis Stals
Occasional Advisor

Re: Problem with OVSD 4.5 SP21 upgrade to SP25

I attach screenshot

Re: Problem with OVSD 4.5 SP21 upgrade to SP25

Did you exactly take the steps (with the reboot, and the services stopping before the upgrade)?
Frans_F
Honored Contributor

Re: Problem with OVSD 4.5 SP21 upgrade to SP25

If the above did not help please log a case with hp support if you did not already do so. You need to supply the logdatabase.txt file which will contain the upgrade information. For a quicker resolution you also need to supply a copy of your database then they can run the upgrade and analyze the problem (if possible).
HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
//Add this to "OnDomLoad" event