Service Desk Practitioners Forum
cancel

Problem in data exchange in SD 4.5

Highlighted
aks3183
Super Contributor.

Problem in data exchange in SD 4.5

Hi all,

I exported an excel file to an xml file. The class i used for it contained four fields as in excel sheet. But after exporting i am getting an extra field "ID" in xml file and this field is not present in class defined.

So when importing xml file to cmdb i get an error that entity "ID" is not a part of class and so the data is not getting imported. Can anyone tell me how to tackle this extra id field?
4 REPLIES
Ramaprasad N
Outstanding Contributor.

Re: Problem in data exchange in SD 4.5

Hi,

This ID field is the default field created by SD during the data exchange. This doesn't need to be mapped to any of the attribute in the import mapping. However, make sure that you don't have anotehr field by name 'ID' in the export configuration. You just ignore this ID attribute and do the rest of the mappings for the defined attributes. The data exchange process should work fine.

Kindly attach the export configuration file and the log file for more troubleshooting here.

-Ram
aks3183
Super Contributor.

Re: Problem in data exchange in SD 4.5

Hi Ram,

Thanx for ur reply.

The class i created is "Exceltest". Attache are the log files and configuration files.
aks3183
Super Contributor.

Re: Problem in data exchange in SD 4.5

Thoe log file is attached:
Pritam Majumder
Respected Contributor.

Re: Problem in data exchange in SD 4.5

Hi Akash

Seems there is some mismatch with the classname provided in the xml and that in the import mapping. Can you provide a screen shot of the imoprt mapping. Meantime you can make the lowercase to uppercase in the ini file for the Class EXCELTEST.