The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
Service Desk Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Passing NNM Events into Service Desk

Highlighted
Wynford Thomas_
Regular Collector

Passing NNM Events into Service Desk

Hi all

I'm using NNM 7.5 win and Service Desk 5.0 on Win2003.
I'm trying to pass an NNM ov_node_up event to SD to create an Incident, but cannot get it working.

This is the command executed on the command line to initiate an ovevent OV_NODE_UP event:

ovevent -a "" .1.3.6.1.4.1.11.2.17.1.0.58916864 .1.3.6.1.4.1.11.2.17.2.4.0 OctetString "testing testing"

This completes ok, produces an NNM event in the browser, and in the ovactiond.log file, but doesn't create an SD Incident.

The OV_NODE_UP event has been configured with the following automatic action command:

"F:\Applications\\HP OpenView\lbin\obs\loadobject\OvObsLoadObject" -f "F:\Applications\HP OpenView\lbin\obs\loadobject\ovsdnnmevent.conf" -v event_id="$2 $x $X",description="$2 is Up at $x $X""

When this automatic action runs, it doesn't create an SD Incident, but when executed on the command line it does create a SD Incident, but not end to end.

Help appreciated.

Regards, Wynford



1 REPLY
Ragu_4
Regular Collector

Re: Passing NNM Events into Service Desk

Have you created the DB rules and user with NNM_ according to documentation. We use from OVOW and works fine.
//Add this to "OnDomLoad" event