Service Desk Practitioners Forum
cancel

POOR DB Integration performance - SD 4.5

Highlighted
Molez
Regular Contributor.

POOR DB Integration performance - SD 4.5

We have a relatively large implementation of HP ServiceDesk 4.5 (sp11) running up to just over 2,000,000 Service Calls over around 3 years.

We have 8 application servers running on HP-UX servers. 1 of those has been converted to an integration only application server (no client connections, no join multiple servers)

However, even though the integration server is only processing around 450 items, we still have a lag of nearly an hour on some of the automation firing.

Any suggestions of things to look at?
3 REPLIES
Jov
Acclaimed Contributor.

Re: POOR DB Integration performance - SD 4.5

Check your query return results and the likes as they might not require to be as large as the default. Tune these and it might be a start.


Jov
Molez
Regular Contributor.

Re: POOR DB Integration performance - SD 4.5

We've found that the application server which we were using for integration (and normal user load) was running at up to a 20 second delay for the DB, we increased it's number of connections and then stopped users from connecting to it.

We've got rid of the lag to the DB, but these particular database rules seem to be going particularly slowly.
Jov
Acclaimed Contributor.

Re: POOR DB Integration performance - SD 4.5

You'll have to examine your rules and triggers to see why there is such delays. It could also be a backlog??


Jov